HELP! Problem with my new 7D's pop-up flash!

Discussion in 'Canon EOS' started by park_trot, Jan 28, 2010.

  1. I recently purchased a 7D. I had been using it with my 580EXII with no problems. Today I went to use the pop up for just a touch of fill flash and it would not open when I pressed the little button on the side. I even tried switching to fully auto mode (green box) and it would not open. I then went in to the menu and it will not let me into the built in flash menu. It says "menu can not be displayed. External flash is attached." I have checked the contacts, i have tried reseting all the settings, I have tried pulling the batteries. Any thoughts?
     
  2. Unless something has changed with the 7D, in full auto mode the flash button will not pop-up the flash. In auto mode you give up control.
    You should test in P mode to be sure, but the fact that the camera thinks the external flash is displayed, you should check the micro-switch located within the flash mount. It's probably depressed thus the camera thinks the external flash is still there.
     
  3. I'll second Rob, micro switch is stuck..
     
  4. how do i "check the micro switch"?
     
  5. Yep, MS is stuck. Common problem with EOS since the 1980s, especially if you really tighten the flash foot. Pry it up the rail with a toothpick and all should be well. Happens to every year or two. No biggie.
     
  6. In the field, get your fingernail under the edge of the flash "cowling" before you press the button, then pull up as it starts to click. Often the problem will not re-occur for a while. An earlier post with a picture of where to work on a temporary fix is at (link ).
    This problem is one that has been around long enough that Canon should have figured it out by now.
     
  7. Brilliant! My 40D's popup won't pop up either. Might be a good thing regardless.
    Microswitch ehh? Not even mentioned in the (7D's) manual. Weird. How was known or found out?
     
  8. I've struggled with the problem on my 20D for years. When the flash is up I filed off a little of the edge - enough for me to get a fingernail in the slot that I made. When the "clicking" of the microswiitch begins I put my fingernail in the slot and then it opens.
     
  9. Micro-switch plunger is under the right flash rail. Right here...
    00Vd5u-215123584.jpg
     
  10. Park,
    Same camera, same exact problem. I've been reading about the micro switch, but I can't figure out which way to flip it or pop it or whatever. Do I push it down or towards the camera eyepiece? Thanks in advance for the help.
     
  11. whew... thanks so much for this post, as I sit here trying to figure out why the flash won't pop up on my 7d after using the 580 ex for so long... same issue... you'd think Canon would address it in the manuals!
     
  12. Thanks, that helped a lot. I was able to fix it in about 30 seconds.
     
  13. Same problem on my 60d except I couldn't see where a micro switch was stuck under a rail. So I VERY, VERY gently took a small knife and put a TINY, TINY bit of pressure on the two side rails. Up periscope. No problems. Wouldn't recommend to much pressure if it dose not work first time though.
     
  14. Had the same problem at the most unwelcomed time. Followed the advice, got my fingernails under the sides of the flash, and now all is well. Would like some more detailed advice on how to lubricate the switch.
     
  15. state of the art. I guess you don't mess with perfection. ;)
     
  16. Wish I had read this 2 months ago. Same issue, took to Canon in Jamesburg and $160 later it's fixed. They claimed they replaces some internal this or the other. Probably just did what's stated here and charged me $160.
     
  17. This was helpful, but I've got to say that having this happen on my new 7D after just a few months is very disappointing. Having bought a camera one reviewer described as "industry changing" only to find out how cheaply this part is made--and, further, that this is a long-standing problem that Canon simply has not addressed makes me feel like I own something kind of cheap, and flimsy. This has cast a bit of apall over my opinion on Canon products. This is very disappointing. But thanks for the tips.
     
  18. Hi John. I bought a 60d and had the same problem plus the glue on the grips is giving way so that needs to be fixed. Swapped over from Nikon and I get the feeling Nikon's are better made. Not better camera's, just better made, though i'm sure Nikon have their problems too. Don't mean to start a war or anything.
    Good luck, take care,
    Al
     
  19. Hi Al, no argument from me, though I suspect my pal would say something similar about his Nikon, now that the lens seat has detached itself from the body. I think we're now, generally, in the new Age of Shoddy.
     
  20. Bought my external flash 430EX II fall of 201, I have been using it all this time. Just a few days ago had the same problem with the my 7d thinking the flash was attached when it wasn't. Found this forum & 10sec later with the help of your picture of the micro-switch plunger, I fixed it! Thank you very much! I was stressing big time. I guess I carry around a toothpick in the camera case. Strange Problem for Canon not to fix already.
     
  21. Hi Pam, For what it's worth it only happened the once, although I rarely use the pop up.
    Good luck, take care.
    Al
     
  22. I'm sure glad I found this. My pop up has been stuck on my 7D for several months and now it works fine. Thanks everyone for the valuable information.
     
  23. I just discovered this problem with my on board flash not popping up and initially thought it had something to do with the menus. I started to dread having to send my 7D in for service. A quick internet search later and I find this thread and moments later my problem is solved!
    Thanks for the info and that picture showing where the stuck button was hiding.
    @GraphicDesignNY
    GraphicDesignNYC.net
    00auAY-499035684.jpg
     
  24. Better late than never, I guess! I sure am glad I found this thread. Thought my 7D pop-up was broken when the only trouble was that micro switch. Surely Canon could post something about this problem - or have they? I couldn't find anything from them. You guys are the best! Thanks a million!
     
  25. Thank you so much , thought I was going gto have an expensive repair.
     
  26. Thank you for this. Yesterday I bumped my camera with my Speedlite on it and ended with with my pop up being stuck. Reading this helped me fix the issue. The bump cause the metal leaf spring to stay depressed thereby activating the micro-switch and hence making the camera think I still had my Speedlite on which resulted in my pop-up being stuck. I gently eased the leaf spring back and voila! Thank you for helping me avoid a costly trip to the service center.
     

Share This Page