Help: 5D2 AF Point Selection not functioning

Discussion in 'Canon EOS' started by joshuat (syd, aus), Jan 11, 2013.

  1. Hi,
    I bought my 5D2 new a couple of years ago and I've recently just come across an issue where pressing the AF Point Selection button won't allow me to select the focus point.
    I know the button physically works because when reviewing photos I can use it to zoom in and out.
    I've also tried reflashing the camera's firmware without any change.
    Any suggestions to rectify this would be greatly appreciated.
    Josh
     
  2. Chack the custom functions. One of these settings controls the AF functions although I'm not sure it affects the AF point
    selection button. Take the backup battery (button cell) out for a couple of minutes, this will reset the camera to the default
    settings.
     
  3. Make sure you activate auto focus by depressing the shutter button half way before trying to select the auto focus point. If the camera has been inactive long enough to go to sleep, the selection wont work till focus is activated.
     
  4. If you're in full auto mode (green square), most of the user options are disabled. You need to be in the "Creative Zone," e.g., P, Av, Tv or M. If that's not the problem, reset the PRAM by pulling mains and backup (clock) batteries. If that's not it, next stop is Canon Service.
     
  5. So is it healed yet?
     
  6. Im aware that the camera needs to be 'on' for the autofocus point to be selected. thats not the problem.
    I can confirm there do not seem to be any issues with custom functions. They have all been factory reset.
    Is there a green square or automatic program on a 5D2? If so I've never used it. That's definitely not the problem.

    I haven't managed to get to the backup battery yet, I'll give that a go tomorrow.

    At this stage it's still not working correctly.
     
  7. I tried the reset by removing both batteries and it seems to have corrected the issue.
    Not sure what it could have been.

    Thank you one and all for your suggestions.
     

Share This Page

1111