Have I stuffed my card?

Discussion in 'Canon EOS' started by jim_pritchard, Dec 29, 2009.

  1. Hi All,
    The mrs gave me a used eos300d for xmas, and I think I may have wrecked the card...
    It was fine until I removed it, took of the pictures, but when I put it back in the camera, I get "error 002"...
    I am not sure if the camera was turned off when I removed the card, looking back on it, I fear that this could be important... advise please?
    Thanks
     
  2. Did you format the card? If you did, the card is probably dead. Good news is these cards are petty inexpensive these days.


    If the camera is an SD card maybe the card is set to LOCK. Can you take this card out of the camera and stiff see images on your computer?

    More details will help solve the poblem.
     
  3. Jim check the camera lens mount make sure the lens has not come half un-done - as Bob said a format would be ok then I would re-set factory default settings - last - try another card.
     
  4. The 300d uses a compact flash card which as the other poster said are cheap enough to replace. The error 002 is indeed indicative of a card fault. Put the card back in the camera and use the camera options to format it. With a bit of luck it will rectify itself. (N.B. formatting will erase all data on the card so any shots on there that are not backed up will be lost) If you cannot format from within the camera (always the best option btw) then put it in a card reader and format it to FAT16. Good luck.
     
  5. First, try formatting the card in the camera. If that doesn't work, try a new CF card (which you should also format in the camera). You can also try reinstalling the firmware, which you can download from the Canon website (read the instructions carefully).
     
  6. I have managed to format the card via a card reader, but I cannot get the camera to recognise the card ( hence the error 002)
    The camera DOES however take shots with the internal memory of the camera.. so at least I know the camera is still working....
     
  7. Jim, have you tried formatting the card in the camera? That's what Canon recommends, and it might make a difference.
     
  8. sorry guys, how do I do this? as soon as I put the card in, I get the error mentioned above.. how do I get to the point where I can reformat the card?
     
  9. I think your next move is to try a new CF card. At least to make sure the fault is card or camera. But first have a look into where the card mounts and check that none of the pins are bent, you will need a torch and good eyesight or a magnifier for this. If one is bent they can usually be straightened with care and some very slim tweezers or similar. If you can't manage this take it to a good repairer. I did have this on a 300D and fixed it, never got another problem, Good Luck!
     
  10. Turn the camera on and open the menu, then use the right joy-stick button on the back to move the cursor to the first tool icon (second icon from the right). "Format" will be at the bottom. Scroll down to that and open it (center joy-stick button). Using the buttons again, select "OK" and open it. The rest is automatic. If you still get the error, you probably need a new card.
     
  11. By the way, if you don't have the manual for the camera, you can download a PDF copy at the Canon website. It's the last item in the Guides and Manuals section.
     
  12. I am at work at the moment so cannot check, but I think that the one of the pins is actually bent.. no idea how I have done this, but if I straighten it and it snaps off, will it still work, or do I need all the pins?
     
  13. You need all the pins. If one breaks off, the camera is toast (except for shooting tethered to a computer), and you'll need to have some serious work done at a Canon repair site. If you're in doubt at all about your ability to straighten the pin without breaking it, take it in for service.
     
  14. cheers guys.. off to the camera shop in the morning.. only had the damn thing for 4 days...
    :eek:(
     
  15. Unless you are very lucky, you'll need all the pins. There are some duplicate pins (I think there are 3 or 4 ground pins for example) and one of two pins might not be used, but I think there are 16 address lines as well as 16 data lines, plus some control signals, so most of the pins are needed.
    If the shop can't straighten the pins, it may almost be as cheap to buy another camera as to get that one fixed. The socket is under $10 as a part, but there is a lot of delicate work involved in taking the camera apart and replacing it. I'd expect a charge of maybe $150 to replace the CF socket if that's all that needs to be done (and it sounds like it is)
     
  16. If you are unsure as to your ability to get the pin straight maybe get a quote to replace the unit and if it's a shed full of money then have a go yourself. As I said I did one myself (and that was laying flat!) and never had any more problems, the pins do seem fairly resilient if you're gentle. And if you do break it off what have you lost? You already know the cost of replacing the unit and you can then either have that done or get another camera, whichever is cheaper!
     
  17. If you are "handy" then I'd agree that trying to straighten it yourself would be the way to go. Magnifying glass and tweezers would be my tools of choice. If not, then I'd see if the repair shop could try to straighten it for you. You'd have to make it clear to them (and maybe put it in writing) that "best effort" is OK and if they break it while trying to straighten it, you won't hold them responsible.
    Odds are it will break of course. If it doesn't, it will be weakened and may break off in the future. In that case it could get stuck in a card or (worse) it may short out some of the pins and cause electrical damage. Because of this some repair shops might be reluctant to do the "cheap" repair since it could come back to bite them in the future if and when the pain finally breaks.
     
  18. I broke a pin off in an S50 once, it still worked fine for years, so don't give up all hope.
     
  19. I did a quick Google on this error code, here is one item that turns up...
    Err 02: CF DRIVER

    DESCRIPTION: This error occurs when image data cannot be written to the CF card. This error can occur when the CF card is not fully seated in the camera or if the D60 does not detect a card-ready signal within a specified time limit or when the CF card is not usable because it has been corrupted or physically damaged. It can also occur when the camera's battery level is insufficient to completely write the file to the CF card.
    REMEDIAL MEASURE: Use the DC Coupler or recharge the battery first. If the error continues to occur with sufficient power available to the camera, check that the CF card is properly inserted. If that's not the problem, then try replacing the CF card. If that does not solve the problem, have the EOS D60 and one of the CF cards that is causing the problem examined by a qualified service technician. This error is similar to Error 22 on the D30.
    This note was found on a page explaining the 5 error codes used on a Canon D-60, but it also said the same error codes were used on other models, including yours.
     
  20. I know this seems obvious, but is the card in the right way. It could be backwards or upside down.
     

Share This Page