[Hasselblad] - lens shutter problem - B setting

Discussion in 'Medium Format' started by redimages, Nov 29, 2004.

  1. G'day from Australia,

    I've just bought a second hand 500c with a 80mm f2.8 planar lens (NR)

    All shutter speeds except B work fine. B setting does not keep
    shutter open at all, it clicks open/close about as fast as 1/30sec.

    Any ideas on a quick fix or is it a trip to the repair shop?

    Thanks in advance,

    Peter Marsden
     
  2. Not a Hassey person but I think on B(bulb) the idea is as long as you hold the button down, the shutter stays open. It is usually used with a remote release for long exposures timed manually. It may have a default of 1/30 if not held down.
     
  3. Peter:

    Does the shutter stay open if you hold the button down? If so, it works correctly - although not the way you might wish it would.

    If it closes even if you're holding the release button down, you'll need to head to the repair shop.
     
  4. On the 500 C there is a little lever near the shutter button, if you move it to T position then fire the shutter, the button stay pushed untill you move the lever to O position. This is usefull for long time exposure without using a cable release.
     
  5. Peter,

    With the shutter set to the "B" setting, the shutter should stay open for as long as you hold the release button in. Are you holding the release button in? If you are, and the shutter is not staying open, there is a problem in the lens shutter.

    David S. Odess

    Factory trained Hasselblad technician

    www.david-odess.com
     
  6. Peter,

    I had purchased a 150mm Sonnar C lens that exhibited similar behavior at B. Since I
    bought the lens for long exposure astrophotography, this was useless to me. The mail
    order firm I had purchased it from had another lens in similar condition and they
    exchanged it for me. If shutter with the lens on the B setting does not stay open while the
    shutter is continually depressed, then the lens can not be claimed as having all shutter
    speeds working properly. Mr. Odess would be a better judge about what the cause/
    symptoms of this are once you answer the main question everyone seems to be asking...

    Taras
     
  7. I have held my finger down/locked my cable release for years, so am disappointed that this lens won't let me.

    Will be heading down to the repair shop soon...
     

Share This Page