Great Wall DF-4: Properly Loading Film?

Discussion in 'Medium Format' started by angelo_inanoria, Jun 9, 2004.

  1. Does any one know how to properly load film into this camera? The 120 spool seems to be a bit bigger that what it can handle(?). I'm hoping it's just me and I'm doing something completely wrong.
    For those whose not very familiar with this, it's a chinese TLR that also sometimes encarnates as "Chang Cheng" camera. It's considered a crappy camera but can take fairly decent pictures nonetheless.
    Any info is greatly appreciated!
     
  2. I thought that the Great Wall was an slr based on the ancient Pilot. I had a Great Wall briefly and had no problem loading it. I remember that the main challenge was viewing the image through one of the dimmest waist level finders I have ever seen! If you have a tlr then again, I have always found the chinese tlrs perfectly easy to load. Could you give a little more detail on just how you are struggling?
     
  3. I have the same model standing next to me - at least according to the name: Mine is a SLR with a M39 screw mount. A nice, very basic camera. It takes a normal film spool of 120 film. Film loading itself is nothing specail, maybe you have just the wrong spool? You might try a standard one, it should work.
     
  4. Oops! My bad; it is an SLR with the M39 screw: Great Wall DF-4. I'm using the normal Tri-X and Ilford FP4 120 films. I'm having trouble slipping the new spool into place because it seems that the knob that would hold it in place is in the way of loading.
    I've been trying to figure out if there's some kind of release to open up the way(?) so the spool will just drop in. So far I'm not seeing it.
    BTW (Off topic): I've experimented replacing the focusing screen with an old Hasselblad acute matte focusing screen; I know this may sound stupid; had to shave off a bit from the sides but it worked. Now the view finder is a lot brighter than the original.
    Now...if someone can only tell me something about this film issue...(sigh)
    Thanks in advance for all the help!
     
  5. I know this reply is years late...but I will respond in case any Googlers find it like I did.

    I just got my Great Wall camera and figured out the issue. Luckily, I had Kodak, Ilford and Fuji film lying around. My Kodak would not fit. It is less than a mm larger than the spool that was in the camera when I bought it. I tired the Ilford too...no luck. I looked at the spool that was in the camera when i got it, which loads perfectly. It says "Fujifilm EZ load". I grabbes a new roll of fuju color 120 film, opened it and saw the same emboss on the spool. I tried to load it into the GW and Voila! It worked!

    So I guess from now on I can only use Fujifilm in this cam. My guess is that this camera was made when spools were metal. The metal spools were a bit thinner i think, on the top and bottom and now only fuji fits.
     

Share This Page