FM2n lightmeter issue

Discussion in 'Nikon' started by mehrdad_abadani, Jul 26, 2012.

  1. greetings,
    i have been given an FM2n with faulty lightmeter.
    the metering redlights do not function.
    however, when the MD-12 winder is attached, the lightmeter works properly but you can not operate either the winder or film advance lever.
    any suggestions mostly appreciated.
    M
     
  2. It could happen that there is some corrossion on the camera`s batery contacts. Have you checked it?
    About the winder, I don`t know. If the winder lever doesn`t work with the winder attached, nor the winder, my guess is the winder is jammed, but I cannot assure it.
     
  3. thanks Jose,
    the battery comp. is clean and free from corossion.
    the winder works perfectly on other cameras.
    the advance film lever on camera is ok on it's own too.
    i am thinking it is more of a short circuit somewhere, but where exactly,...?
    M
     
  4. If the winding lever is in "on" position, the shutter speed is in other than "B", the battery compartment is OK and fresh batteries doesn`t make the meter work, definitely the camera needs professional repair.
    About the motor drive, which one are you using? It could be convenient to specify, there are slight differences working with the MB-11 or MB-12. If the MB-11, think that you have to switch off the unit to turn off the camera`s cells, if not, they will be drained way faster than you`d expect. Also, if I recall correctly (I`m not sure at all), the MB-11 doesn`t let you to use the camera`s shutter release button.
     
  5. First thing: The camera leverwind should be pushed flush for the MD-11/12 to work. Pulling out the leverwind will disable the motordrive. There's a downloadable manual for the MD-12 here. The MD-11 is practically identical.
    Now let's break this down to what's working and what isn't.
    1) The lightmeter itself can't be faulty since it works with the MD-1X attached.
    2) The lightmeter obviously isn't getting any power from the camera battery - therefore camera battery and contacts need checking and cleaning.
    3) Power goes from MD-1X to camera, but doesn't wind - those old winder grips are renowned for poor battery connections - so again the batteries, battery box and internal terminals need checking and cleaning. It's possible that there's enough voltage/power to work the meter but insufficient to wind the film.
    I have a good deal of experience with electrical/electronic equipment, and 90% of the time a "fault" turns out to be down to incorrect user operation or poor/broken contact(s). CLEAN all battery contacts thoroughly using non-metallic and not too abrasive material. To do this remove any obvious blue or green corrosion with something like a plastic stick or a purpose-made fibreglass brush. Then use a small amount of liquid metal polish on a cotton-bud (Q tip) and polish off.
    Install NEW FRESH batteries all round. The gold-plated contacts between motordrive and camera are rarely a problem, but the spring contacts in the MD-1X battery box are a pig to get good contact from once they've corroded, and so are the contact "pips" deep inside the motordrive. The old trick of rolling the batteries around might help. Good luck!
     
  6. thanks Rodeo J,
    all the compartments are clean.
    the MD-12 works with my other cameras.
    as you have mentioned there is no power between the batteries and lightmeter system.

    so, it all points towards electrical issues within the body. i am afraid.
    cheers anyway.
     
  7. Mehrdad, check the camera battery and battery compartment (again!). I've had the case where the individual button cells check out OK on a voltmeter, but when stacked together in the camera they don't make proper contact with each other. Also make sure they're inserted the right way round. Sounds obvious, but it's something my daughter never seems to be able to get her head around. She's brought me her camera to "fix" several times, and each time the button cells have been in upside down. The smaller terminal is negative and the cells need to be inserted in the removeable holder of the camera with the smaller contact down, so that the positive outer casing goes into the camera first.
    One other thing. Try not to use alkaline button cells - they're rubbish. They don't last long and they tend to leak. You can get a single 3vLithium cell - type L1/3N - to replace the two SR/LR44 cells. They're a bit expensive and more difficult to find, but they'll last at least 3 years in the camera and are almost completely leakproof.
     
  8. Actually, all the problems I and others have had this type has been contact issues, so it`s hard to believe there is something rare and complex like a short circuit inside a camera... what Rodeo says.
     
  9. thanks again R.J
    i have tried different batteries on this and other cameras, and the result is the same.
    have cleaned the compartment few times, to no avail.
    as i mentioned before, the lightmeter red lights operate only when the MD-12 is attached, but the winder is disabled.
    when i disconnect the winder, the lights operate for another 2 or 3 advances on the lever, and then off completely again, until i repeat the procedure.
    quite puzzling.
     
  10. Mehrdad,
    I had a similar problem to yours a number of years ago. I found that by screwing in the battery compartment cap finger tight, the light meter worked. If it was screwed in coin tight, it short circuited and did not work. The loose fitted battery cap was kept in place by the MD-12.
     

Share This Page

1111