Firmware 2.0.8

Discussion in 'Canon EOS' started by andrew_neill, Nov 4, 2010.

  1. I have been trying to update to Ver2.0.8. The file from Canon does not self extract. I have tried this on XP and Vista to no avail. Can anyone tell me why?
     
  2. I had no problems installing it on Windows 7 (32bit). Try deleting the file and downloading it again. See if that helps.
    http://aux1.jp.canon.com/eosd/firm-e/eos5dmk2/data/eos5d2208.exe
     
  3. use the Canon USA link
    worked fine on Windoze 64bit
    disable virus scan before you try to extract the firmware file .FIR file
    http://www.usa.canon.com/cusa/professional/products/professional_cameras/digital_slr_cameras/eos_5d_mark_ii#DriversAndSoftware
     
  4. Tried all that but it remains zipped?
     
  5. Is anything happens after you double click the downloaded file?
     
  6. Is the file suffix .ZIP or .EXE? Windows treats .ZIP files as folders. To extract a file, you drag it to another folder. If the suffix is .EXE, then it should extract itself when you double click it.
     
  7. I download the .exe file then attempt to to extract when it becomes .zip file.
     
  8. What do you mean when it becomes .zip file? I just downloaded it again, double-clicked on it and it now asks me where to extract the file. I selected Desktop and now see .fir file on my Desktop
     
  9. Ilya, That,s what I do but the .fir file becomes a .zip file instead!
     
  10. Ok, don't try unzipping it. .fir file is what you need to do the upgrade. Connect the camera and use EOS utility to do the upgrade. Most likely you have .fir extension associated with WinZip so you see Zip icon.
     
  11. [[Ilya, That,s what I do but the .fir file becomes a .zip file instead!]]
    Do you mean the icon is the same as a ZIP file icon?
    If that's the case, your computer has somehow come to associate .FIR files with your Zip File extraction tool. If the extension of the file is still .FIR, it doesn't matter what the icon is. It's still a .FIR file.
     
  12. Doh! Crossed electronic paths with Ilya...
     
  13. Ilya. It's a FIR file but it's zipped.
     
  14. Don't worry about what icon do you see. Just go ahead and do the upgrade.
     
  15. But a zipped file will not update the camera. I have used two comps and two OS.
     
  16. Have you tried actually upgrading the firmware with the file or are you making an assumption based only on the icon of the file?
     
  17. You can try the upgrade and see if it works. If it isn't the right file, then the camera will not "see" it and it won't flash the firmware. Another thing you can do is check and see if the file size is the same as Canon says it should be (for a recent firmware upgrade on my 7D, the instructions said to verify the file size). A zipped file will show a different file size. Also, right click on it and check the extension of the file. If it says ".fir" then you're good regardless of what the file icon looks like. If it is a zipped file, then it will be ".zip".
     
  18. Thanks Rob, that's it I've put the file on the cf card and it's updated. I've had two 5Diis since they were available in the UK and done a few updates on both.
     

Share This Page