FE2 film advance stuck and mirror locked in up position

Discussion in 'Nikon' started by efusco, Apr 8, 2004.

  1. My father recently purchased, via the 'bay', a used FE2. He's new
    to Nikon as he was a dedicated Pentax shooter previously. He called
    me last night with a problem.

    Mind you, I haven't gotten to look at the camera yet, but he's
    bringing it by this evening. I'm hoping to get some
    advice/suggestions on thing to check and try to fix his problem.

    While trying to load film (which he was unsuccessful doing) after he
    closed the camera back he found he could not advance the film
    advance lever and the mirror was stuck in the locked up position.
    His efforts, thus far, have not been successful in restoring
    function.

    Any suggestions on where to start? I e-mailed him to try new
    batteries.
     
  2. First step with this camera is to set the shutter to M250 and try to release. M250 and B are mechanical and battery independent. SEE HERE for an online HTML manual.
     
  3. Probably the battery is the problem. As above though, set the shutter dial to the M setting or B and the mirror will drop down and you can advance the film.

    If this is not the problem, I would be very surprised.
     
  4. Thanks guys, the manual and the advice will help. I'll report back if that doesn't do it.
     
  5. I've occasionally had a similar problem with the FE2 and an FM2. WIth the FE2, I had
    it happen when I first bought it and accidentally half-cocked the self timer -- it
    stayed partly "cocked" and didn't run down. I was able to unfreeze it by completely
    cocking the self-timer and then having it run down. Sometimes just fiddling around
    like that can help.
    There was also advice recently on how to un-stick the shutter of an FM2 that might
    apply to an FE2. Please remember, however, that the shutter of the FE2 is VERY
    delicate!!!

    Good luck. Please let us know what happens.
     
  6. I'm pretty sure I've got the answer to this one. It happened when I first owned an FE2.

    Something can cause the camera to get out-of-sync while loading film, and the advance lever ends up locked because of it. The owner of a local camera shop fixed mine in seconds.

    Remove the bottom plate of the camera (requires a tiny philips head screwdriver). On the end where the winder mechanism is, there will be a lever engaging a cog at the bottom of the assembly. Manually move this out of the way and the advance lever will move as it's supposed to. You mentioned that the mirror is in the up position - this should be manually brought down first.

    Someone else on photo.net had this same problem, and I received a personal email from him letting me know that my solution saved him $200, which was what a local repairman had quoted him. That made my day, and his!

    If you're not comfortable opening up a camera, at least you could tell a repairman what is more than likely wrong so that a bunch of time (and $$$) isn't wasted.

    Eric
     
  7. Eric you're talking about resetting the wind lock. First thing to check if the mechanical release doesn't work, otherwise its some sort of battery/electronics issue.
     
  8. Thanks all for your responses. My father should find the instruction manual handy (I don't think he had one). He was turning the take-up spool the wrong way to load the film....we've corrected that.

    When I got my hands on the camera I tried pressing the shutter and making sure there was nothing else wrong, turned the shutter speed dial to M250, and down went the mirror. Loaded in two fresh batteries and tested at all shutter speeds and it worked fine.

    Thanks for the help.
     

Share This Page