F4 not firing from hotshoe despire communicating

Discussion in 'Nikon' started by david_richardson|12, Nov 29, 2016.

  1. I was wondering what anybody thought could be the problem. My SB 24 flash fires with other cameras and it know what film I have and what lens I'm using, but It will not fire. I was wondering if anybody had any suggestions?

    Kind regards
    David
     
  2. Can you try another flash?
    I tried an SB 15 on my F4, which has worked in the past, and initially it did not fire from the hot shoe either. I tried several times, with different settings, no go. But it fired from the PC terminal. I then tried another non ttl flash, and it fired from the hot shoe. When I put the SB 15 back on, it started firing from the hot shoe again. When I looked at the hot shoe on the F4 it was a bit dirty (the camera has sat for a while, and even when I used it a lot I rarely flashed), and I wonder if that was enough to do it.
    Anyway, it would help if you could find another flash, or get a sync cord, and see if the behavior changes.
     
  3. David,
    the finder of the F4 is removable, maybe you can try to clean the contact of the hotshoe, as well as the contacts between the finder and the camera body itself .... this may do the trick.
     
  4. most likely the big center contact on the hot shoe is either dirty or worn.
     
  5. ShunCheung

    ShunCheung Administrator

    A long time ago, my F4 wouldn't fire the SB-24 I put on it. The problem turned out to be the contacts between the removable viewfinder and the camera body. It got worse and worse. Eventually the electronics in that F4 died altogether.
     

Share This Page

1111