"F--" error with Tamron 28-75 f/2.8 and D90

Discussion in 'Nikon' started by zack_mccrory, Mar 30, 2009.

  1. I just got back from a weekend trip, and had some problems with my new setup


    I lost out on a lot of good photo opportunities because my camera kept flashing "F --" on the top LCD screen. Sometimes if i turned the camera off and then back on it would fix it, but other times it wouldn't.


    In addition to that, i was trying to take some low light photos and it never would quite focus (was indoors at an aquarium). I took my 67mm Tifen UV filter off, and it seems to help a bit, but not much. It was also having some problems focusing on objects far off in the distance (was in Gatlinburg, and wanted to take some photos of the mountains).


    I have only had this setup for a couple weeks, and it seemed to work fine at first.


    After much frustration, i finally threw my Nikkor 50mm f/1.8 on there, and it seemed to perform fine.


    Do you think there is a defect with my Tamron lens? i have heard of some AF problems with non-nikon lenses, but this was a little extreme. If there is genuinely a problem with it, i want to figure it out now so i can return it. Its really frustrating to pay $400 for a lens, only to have it not act right.


    I guess i should ad that both the D90 and the Tamron lens were puchased new about 2 weeks ago.
     
  2. Zack, do you have the smallest aperture set on the lens?(The highest f/stop number)?
     
  3. Did you lock the Tamron's aperture ring at f/22 (or whatever the most closed-down value is)? That's necessary to enable the camera to operate the lens' diaphragm. There should be a lock button on the aperture ring that engages at the smallest aperture value.
    In terms of autofocus, you may have been in too little light for the Tamron's f/2.8 lens to focus quickly. The 50mm f/1.8 might have focussed better because its f/1.8 aperture puts more light into the camera for better autofocus in darker conditions.
    The other possibility for both issues is that you didn't have the Tamron lens mounted fully into locked position on the camera body and the camera wasn't making electrical contact with the lens because the body and lens electrical contacts were not aligned.
     
  4. This lens does not have an aperture ring... just a zoom and focus ring.


    The lens was definitely all the way locked in place.


    Some of the times that it was giving the error, were times that there is no excuse why it wouldn't of had enough light. One we were up in an observation tower in mid-afternoon. It was an overcast day... but there was plenty of light. I shot in much lower light conditions with my old D40/17-55 kit lens combo.


    As far as camera settings go... i just threw it on Auto because most of these were just point-in-shoot... just some pictures of me and my friends walking around. I tried changing the AF point to center and that didn't seem to help any.


    The main reason i purchased that Tamron lens, is because i thought it would be perfect for low light stuff, since my 17-55 f3.5-5.6 kit lens with my D40 worked fine.


    It seems like this lens worked great the first couple days i had it. I was riding in a friends car going down the interstate, and was taking photos of other cars when it was almost dark outside. Now all of a sudden, when i REALLY wanted the lens to perform well... it let me down. I hope its just something im doing wrong, because my $1300 D90/Tamron combo isn't working near as well as my $425 D40/kit lens combo would have.
     
  5. Zack, that error code indicates a non-cpu lens or no lens at all is attached. I suspect that lens is a CPU lens and likely a communication problem between the lens and the D90.
    Mark
     
  6. ShunCheung

    ShunCheung Administrator

    Folks, for lenses with an aperture ring, if you don't set that to the minimum aperture, the error would have been FEE. F-- indicates that the computers inside the camera body cannot communites with the CPU chip inside the lens, and that would have been normal for AI/AI-S lenses that have no CPU.
    In this case I would first clean the electronic contacts around the lens mount on both the lens and the body.
     
  7. The contacts look brand new (they are only two weeks old).


    Obviously the camera seems to be fine... whats the chances that something went wrong with the lens?
     
  8. the tamron 28-75 has an aperture ring, zack. http://www.tamron.com/lenses/prod/2875mm.asp
    [​IMG]
    it's at the bottom near the lens contacts. set it to the minumum aperture value (f/32). make sure you clean the camera and lens contacts and twist the lens into the camera mount until you hear it click. that should fix the 'fEE' message.
    btw, i've had mine for three years and have yet to experience the problem you describe.
    as for the AF issue, sounds like user error to me. without knowing your settings, it's hard to make a definite conclusion, as there are too many other variables. if i'm not mistaken, Auto setting raises the pop-up flash, which should fire the Af-assist light in Af-S mode. but in Program, Aperture, or Manual mode, you should be able to shoot in low light with no flash, since the 28-75 is a 2.8 lens. i'd try using aperture mode set to 2.8, auto-ISO with max of 800-1600 (depending on where you feel comfortable) and a fast enough shutter to freeze motion blur (at least 1/60 for people picks). switch to manual if you can't get a fast enough shutter. also in low light situations try spot metering, since the d40's 3-pt AF can be confused easily, and try to avoid the combination of low-light and low contrast. the only thing the 18-55 should do better than the 28-75 is focus a bit faster (since it has AF-S) in good light at wider aperture settings, i.e 3.5/18mm. by 55mm, you're out to 5.6 so no way should low-light performance be better than a 2.8, even at 75mm.
    obviously sample variation or a lemon lens is possible, but tamron's been making these for five years and it has less of a rep for malfunction as some nikkors, sigmas, tokinas, or other tamrons. i'd try to rule out user error first, then take the lens into a camera shop and have a pro check it on a different body, and finally send it back, only after exhausting all other options. good luck!
     
  9. Eric,
    I was never getting an "fEE" message, just "F --"
    Im confident it was mounted correctly, and clicked in place. The lens has been on the camera since the day i got both of them, and worked fine the few few times i tried it.... although i didn't shoot with it a lot.
    In my experience, the pop up flash only raises up if im indoors or some other low-light environment. In those cases i turn the wheel to "no flash" mode... which is one click away from "Auto"
    Im no longer using the D40... this is on a D90.
    Im still not seeing an aperture ring on this thing. Here is a photo... perhaps im blind and someone can point it out to me.
    [​IMG]
     
  10. ShunCheung

    ShunCheung Administrator

    Since the problem here is the F-- error, it has nothing to do with the aperture ring anyway. It doesn't matter whether the lens has one or not.
    Again, it indicates that the camera cannot communicate with the CPU chip inside the lens. If the connections around the mount look ok and are touching, you might have some loose connection inside the lens. If you can find another Nikon DSLR body to test with it, it should be quite to figure out whether it is a lens issue or not.
     
  11. ok, you're right. tamron apparently has not updated the picture on their website, indicating version II. i have version one.
    by no flash mode, do you mean (P)rogram?
    if it's not a fEE but a F--, then as shun said, it's probably a contacts problem. if you've tried this on two different bodies with the same results it's much more likely it could be the lens. i would still troubleshoot with settings other than auto just to be sure.
    sorry to hear of your troubles, guess i've just been lucky with my two tamron 2.8s.
     
  12. snowboard shot, tamron 28-75 version I w/ aperture ring
    00Sv87-120607584.jpg
     
  13. I was never getting an "fEE" message, just "F --"​
    These young cameras these days, with their language! (Sorry, couldn't resist. Carry on.)
     
  14. Modern electronics are very voltage sensitive. The brand new contacts in the lens might not be seating properly against the camera. It might take more than a couple of coupleing to wear these points together.
     
  15. Have you removed and re-seated the lens a few times? I had this error one time with my Tamron 28-75 and D80, but never since then. Also, it makes sense to clean the contacts. Just because they are new doesn't mean that htey are clean.
     
  16. Do you still have your D40 ? If so, see if the same error occures with THAT body. If it does, I'd say the lens MAY have a problem.
     
  17. Just out of curiosity...where did you purchase your camera? I was going to purchase the D90 online thru ebay and when I called in to confirm my order, the guy was really confusing about the warranty. Said something about not being able to service it in the US if I didnt purchase the additional warranty. I hung up with him and called someone with Wolf Camera and they informed me that there was an ongoing ebay scam from the NY area with gray market cameras. They have no warranty and when they start reading error messages you are pretty much up the creek. There is fraud going on somewhere. Even if you bought your camera from somewhere else, I hope this helps someone out there!
     

Share This Page