Eraser tool not working on layer masks

Discussion in 'Digital Darkroom' started by michael_veit, Nov 12, 2006.

  1. Suddenly the {photoshop) eraser tool stopped doing its thing on a layer mask
    when I'm editing a photo and I don't know why. I "paint" with the eraser and
    nothing show up in the mmask window and no change is exposed in the main editing
    window. Is there some kind of locking setting for masks which might have
    accidentally engaged? I'm stumped!
  2. Hi Michael, I must confess I never thought about using an eraser with a layer mask; usually I'll paint with the brush tool, typically using black to reveal what's underneath and conversely white to conceal. In fact, that's one reason to use a layer mask is you're not erasing any of your pixels.
    Out of curiosity I just tried it and when I used the eraser tool it worked... but it "painted" black in the layer mask just as if I was using the brush tool - so I just learned something from your question that I didn't know!
    Anyhoo... You might make sure you indeed have the layer *mask* selected, rather than the layer itself. (Click on the white box that sits beside the thumbnail image on the layer) If that doesn't work, you can try painting with a black brush, which should accomplish the same thing. Again, be sure you've selected the mask and not the layer itself.
    If the mask is white, painting black will reveal what's underneath. You can also invert a layer mask (Ctrl-I) so that it appears black. Then by using the white brush tool it will reveal the changes you made.
    For example... 1) Open an image and duplicate the layer. 2) Blur the heck out of the duped layer with gaussian blur 3) click on the "add layer mask" at the bottom of your layer's palette 4) Now press Ctrl-I and the white layer mask will turn black and the blur will disappear 5) Using a white brush you can now "paint" the blur back in where you want it. This is very handy!
    Is there some kind of locking setting for masks which might have accidentally engaged?
    The only one I'm aware of is if you were to right-click the layer mask and select "disable layer mask" which would be hard to do inadvertently.
    A few other thoughts: Does your eraser tool work if you're erasing a layer and not a mask? If not and your eraser tool has totally stopped working completely you can sometimes "thump" Photoshop over the head by exiting the program, then hold Ctrl-Alt-Shift *while* clicking on the icon to start the program. (If you're on a Mac use the Command key instead of Ctrl) This resets a Photoshop .ini file that can sometimes become corrupt and returns Photoshop to its default state and can occasionally fix gremlins like this. Good luck!
  3. Oh yeah - the obvious - check to make sure that, when you select your eraser tool, the opacity is not set to zero on the option bar at the top of the screen or you won't see anything change while trying to use it. ;-)

Share This Page