D70 Flash does not fire

Discussion in 'Nikon' started by haris, Jan 25, 2005.

  1. Upgraded my D70 to firmware B 1.0.3.

    Two things as a result:
    - None of the images get tagged with Adobe RBG color profile
    - Flash does not fire after it pops up on auto modes and/or after I
    pop it up in manual-semiauto modes. A press othe flash button
    produces clicks even if the flash is already up--feels like the camera
    has no idea that the flash is already up.

    Anybody experienced similar things.

    Suggestions? I am really no looking forward to shipping it back to
    Nikon or to the dealer. The camera is only a few weeks in my possession.

    Thanks!
     
  2. I don't think the flash problem is related to the upgrade. Exactly the same symptoms happened to me and required a Nikon fix.
     
  3. I have no experience with D70 as I don't own one yet, so no idea about the firmware upgrade. But I do know in general based on my electronics background that if you have immediately experienced differences or malfunctions from original working conditions after the upgrade, which have never by chance behaved like that in camera and are non-fixable by some simple operations such as 'reset' or 'power off/on', or equivalent. There must be an issue (bug) related to the firmware. So you have to either downgrade it to original or manufacturing version or another error-free proved of the firmware (if you're able to) or send it to authorized Nikon service get it resolved. Good luck.
     
  4. I talked to Nikon people, performed a hard reset, downgraded and re-upgraded the firmware and I am at the end of the rope. It seemsl like the camera will have to travel back to the dealer for replacement/repairs.

    If anyone experiences the same thing, Nikon told me that pressing the flash button on the side of the flash box should not produce a click if the flash is already up. My D-70 does, so the present diagnosis is that the camera sensor that is supposed to register the flash position is malfunctioning.

    I'll post the outcome after I get this resolved.
     
  5. Bought a D70 in July and have just experienced the same problem with clicking etc. Anyone reolved their issues yet. I live in the UK so have to mail my D&0 back to the States for repair.
     
  6. I mailed mine back to the seller as it was within the 30-day exchange window. In my case, the camera also did not imprint the color space correctly. I set the JPEGs to be captured in Adobe RGB color mode, but they all invariably were recognized by Photoshop CS as regular sRGB.

    Good luck with your camera. I am still waiting for mine to return.
     
  7. Well, I just received a replacement from Digital4Less. They returned the old outfit with the lense and included a new body in the same box.

    I was happy until I inserted the CF card. The camera simply forze! The greed reading indicator light on the bottom of the back did not come on and start blinking like it did on the previous body. I took the card out and camera was reset back to the original state--CLOCK started blinking on the top LCD panel. Tried it with two different cards both of which worked fine on the previous body.

    I've never been this unlucky. I buy a lot of computer electronics from the cheepest never-heard-of-it manufacturers and very very rarely have a problem. NOW, two defective Nikon bodies in the row! I am very surprised.

    I am sticking with it and sending this one for replacement as well. I hope third time's the charm.
     
  8. I got D-70 #3. Shot over 500 images in the past couple of weeks. Upgraded firmware to 1.0.3 version. Used custom curves.

    So far so good. Knowck on wood...
     
  9. I am having the same difficulty with my New D-70. I don't want to ship mine out either.
     
  10. I am running B 1.02, so I believe the trouble is not firmware related.
     
  11. Moderator's note: I was obligated to delete John's last post because it was a verbatim quote from a Nikon representative who clearly stated that the e-mail was not to be copied to a web forum or otherwise disseminated publicly.
    While the Nikon rep's reply appeared to have satisfactorily addressed the problem, we're obligated to comply with their request. Please keep this in mind when quoting *any* e-mail from any source, business related or private.
     
  12. D70 won't flash after using Sunpak DS20

    I have been using the DS20 as a remote slave unit with no problems until I connected it to the D70 hotshoe.

    It worked for a couple shots but now disconnected the D70 will not fire its onboard flash in any situation. The flash pops up and the lightmeter seems to be working fine.

    I noticed when the DS20 was mounted the onboard flash tried to raise itself but could not fully engage because the DS20 was blocking it.

    I have tried a hard reset and still no difference. Any help would be greatly appreciated.

    PJ
     
  13. I have experienced a similar problem with D70 flash.
    In my case the camera dropped from my lap onto a hard floor
    and ever since I find that the flash does not function,
    and the release lever clicks loudly whenever I half-press
    the shutter (even if the flash gun is in UP position).

    Seems highly likely that the sensor which tells the system
    whether or not the flash is UP is not operating properly,
    i.e. the system never knows that the flash is UP.

    I feel a wallet attack coming on as a repair is required.
    C'est la vie.

    Steve Morris.
     
  14. I'v just this minute fixed mine.

    Just remove the 2 screws from the front of the popup flash
    The rear plastic cover will the clip off.

    Inside you will find a small switch on the right side of the flash unit when it pops up the switch should make, if it doesn't try shorting it with a small insulated item the try the camera in low light and see if if flashes.

    To fix you need to remove the spring-screw from the other side then gently prise the bracket off, then just pull out the small white sleeve on the right hand side of the popup near the switch,
    this sleeve moves in slightly and will not make the switch on the popup flash.

    Gently put the flash bracket onto the camera, be very gentle as the wires are very thin. You will see the white plastic bearing has 2 small clips which need to be through the hole on the bracket the pin which activates the switch will then be in the correct position.
     
  15. Thanks heaps for that Tony I just fixed mine using your instructions. Found it a bit difficult to pull the sleeve out and click it back into position but just had to hook it from the inside with something. My flash only stopped working a couple of days ago and tonight I set about pulling it apart to see if I could find the problem. The camera would not even operate an external flash. Could not find much on my own so did a quick google search and found this.Probably saved me a far bit in repairs if the shop did not know exactly what to look for. Thanks Again!

    Daniel
     
  16. Thats GREAT Daniel I was quoted ?75 + + + and + .Free is so much better dont you think?
    00Ozid-42620484.JPG
     
  17. I had a problem with the flash not working either and posted a solution here: http://mckayhead.blogspot.com/2010/11/fix-flash-on-nikon-d70-dslr.html
    Might not be the same problem but hopefully this helps someone.
     

Share This Page