Could not complete your request because an unexpected end-of-file was encountered

Discussion in 'Digital Darkroom' started by catherine_murphy|1, Sep 12, 2007.

  1. Hi all,

    I just started having this problem with my RAW files. Some of the files appear
    to be corrupted and I am getting this error message in PS. This hasn't happened

    "Could not complete your request because an unexpected end-of-file was encountered"

    I have done a google search but no real answers --

    is the cards?
    the d200?
    photoshop cs2?
    my hard drives?
    sandisk card reader?

    I can see half a preview in bibble, so I've attached the photo. Any thoughts
    would be appreciated!!
  2. This happens once in a while to me in lightroom and I assumed I was doing too many other processing steps at once while it was loading the file, I had to re-import the rawfile again.
  3. I too have had this error message. I don't really know why or how, but I shut down and restarted. It seamed to take care of the problem.
  4. thanks for your comments -- here is another thing I noticed. I downloaded the files to two separate external hard drives. One drive is fine (the one I haven't worked on), the other is not and I am doing about 500 raw files in Bridge at once, saving them out to jpgs. Maybe that is an issue??
  5. If it were me, I'd start by downloading and running a RAM tester from the net.

    In a nutshell, it sounds to me like file corruption - the file system has a few "checks and balances" to ensure this kind of thing doesn't happen, however it's been my experience that faulty RAM seems to have a wonderful way of bypassing all the safeguards.

    If you don't already have good copies of your data written to CD/DVD, bow would be an EXCELLENT time to start (and again, if it were me, if they were really important I'd check those backups on a seperate PC).


  6. I've been having this problem as well. I've seen a number of folks with lots of configurations with this same problem. As an engineer in software, I think this is clearly a bug with Adobe.
  7. Hi there,

    I also had this problem tonight, while trying to open a work PSD file after my machine crashed with a memory parity error (an annoying Dell issue).

    I downloaded the 9.02 CS2 update but that didn't help.

    I then tried switching to ImageReady and opening the file in there. I got the same error, but then.. it opened anyway! :)

    So I resaved the file under a different name in a different location, switched back to Photoshop and... it opened fine.

    So try that if you're having problems :)


  8. I've had this problem after scanning huge 1.15G files from my Flextight scanner. However,
    the last time it happened I simply waited. Also I closed down Photoshop. I think it may
    simply be still, in the background, writing the huge file and I just tried to open it before it
    was finished. After a minute or two, it opened fine.
    Has anyone had this problem with super big scans?

Share This Page