Coolscan V problems when using ROC and GEM, hardware of software?

Discussion in 'Digital Darkroom' started by jorgeortega, Nov 27, 2004.

  1. I have a problem when scanning with my Coolscan V. Everything seems to
    work well until it tries to perform the ROC and GEM features. This
    only happens at the actual scan and not during the preview phase. I
    get a warning that says,

    "There was an error in performing a post processing"

    It used to work fine before and the weirest thing is that the first
    scan after power the scanner on works well and at the second scan I
    get the warning.

    Is it a software or a hardware problem?

    I installed again the Nikon scan software and even updated to 4.0.2
    version from the Nikon site.

    I recently updated to XP2 but as i said the weirest thing is that
    sometimes it works and sometimes not.

    If i do not get a clue here, I will have to call nikon support but
    then I will have to wait until monday.

    Thank you for your help.
     
  2. I use only the ICE which I find useful. ROC, GEM and DEE are always turned off. I prefer to do any post-processing in Photoshop. If I remember correctly, I had similar problems as you when I used these features, but I didn't bother.

    That said, yes, please annoy the hell out of Nikon. If we are lucky, perhaps we will at some point get a new version of Nikon Scan 4 with bug fixes, or even a firmware update.
     
  3. I have had this exact problem with my Nikon 5000 ED since April, 2004. There was no occurence of it from January, 2004 when I first purchased the unit through March, 2004, and then the problem appeared one day out of the blue and never went away. (Other problems come and go on a regular basis.)

    I was/am running a patched version of XP, but no patches had been applied on or around the time the problem first appeared.

    I reported the problem to Nikon in the first week of May, 2004. The support specialist said Nikon had no previous reports of this problem. He had me do a software reinstall and then we did a fair amount of testing over several hours to confirm the problem existed and to see if modifying various parameters would solve it. Nothing we did helped. We also installed 4.02. I've heard nothing from Nikon since then.

    My suspicion is that the problem lies deep inside the software and may be the result of logic testing code that was mistakenly left inside one of the subsidiary code modules while it was being written and tested, or perhaps inside firmware-based logic that is located within the scanner itself. This test code may have been permanently activated by some set of conditions that are/will be very difficult to pin down precisely.

    All this is speculation on my part, but this problem has that flavor about it. So it may very well be that the source of the problem is rooted in both the software and the hardware.

    Rather than powering the scanner down and then up, simply close the Nikon software and then start it up again. You will get one opportunity to use ROC and GEM together before you have to close again and restart. (This aspect of the problem was also reported to Nikon.)

    Most of what I used to do using GEM and ROC together I now do in Photoshop and Neat Image. If I do need it to create a starting point for further work in CS and NI using GEM and ROC together, then I just put up with having to stop and restart the Nikon software.

    The further you get into digital imaging, the more you realize that there is no substitute for learning the more sophisticated digital editing and post-scanning enhancement tools. I think this would be true even I could afford the ever-elusive Imacon 949.
     
  4. Scott,

    Thank you. At least it is good to know I am not the only one having this problem. And that is nothing wrong with my scanner itself. I will have to call Nikon Canda just to see if they have something to say about it. I will keep you posted.
     
  5. Scott, it is funny that Nikon support says they have never heard of that problem. I can hardly imagine that. It is so obvious, and it bugged me right from the beginning. I chose to give up on these features which I find have rather low value anyway.
     
  6. Are you using NikonScnan as a standalone application or as a plug-in with Photoshop? I use it as a standalone with ICE, ROC, and GEM on a Nikon 9000 ED scanner with no problems. I have also used ICE and GEM when batch scanning 12 35mm negatives or 4 645 negatives at a time with no problems. I just started using ROC when I started scanning 30+ year old negatives. I understand some problems occur when used as a plug-in with Photoshop.
     
  7. I have always used it as a stand-alone software.
     
  8. I have a Coolscan 5000 by the way.
     
  9. The problem occurs using the Nikon scan software as a stand-alone application.
     
  10. I found the solution. After unistalling the Nikon scan software, you have to delete the windows register. To make it easy you can use the application included in the Nikon cd on the folder utilities.

    1) uninstall the program. Do not forget to save your settings.
    2) delete the register
    3) install Nikon Scan
    4) everything works as it should. For how long I do not know.
     
  11. Jorge says .... "I found the solution. After unistalling the Nikon scan software, you have to delete the windows register. To make it easy you can use the application included in the Nikon cd on the folder utilities. 1) uninstall the program. Do not forget to save your settings. 2) delete the register 3) install Nikon Scan 4) everything works as it should. For how long I do not know ....."

    In early May 2004, the Nikon technician and I attempted this solution exactly as you have described it, but it had no effect on the problem as it occurs on my PC-scanner setup. At that point, I decided it was best to start looking at other post-scanning tools and techniques.
     
  12. I've been having the same problem just this last week, but I don't use ROC. I'm trying to use GEM, which it seems to get through ok, and DEE at which point it fails. Closing Nikon Scan and restarting the PC doesn't help anymore, it seemed to at first. Now it seems that I have to uninstall and re-install to get it to work.

    I'm running Nikon Scan as a stand alone process, ver 4.0.2, on a 9000. I'm going to try this approach: shutting down Nikon Scan after each scan. I hope it helps, its better than uninstalling it.

    My theory is that there is a scratch file of some kind in the Nikon directory that contains some erroneous data that is causing the problem. Once you get the corruption, you have to uninstall the program to get rid of it. If it were a memory leak problem, it would go a way after restarting the PC, if it was not enough memory it should happen all the time.

    The Short answer is Software problem.

    I'm posting this issue to Nikon's website this morning, it would help if everyone else did the same.
     
  13. Matt, I have 1 gig of memory installed in my PC and generally do my scanning without PS/CS or any other memory hog being active at the same time. No impact on the problem, from what I can tell. Plenty of disk space available for scratch files.

    A corrupted resident data file is a possibility, but the problem as it affects my PC-scanner setup (patched XP using Nikon Scan 4.0.2 against a 5000 ED) has remained consistent: The failure always occurs on the second scan; a Nikon Scan program restart always allows it work properly again just once; and then it fails on the second scan. As is your experience, the failure always happens within (or possibly at the end) of the DEE processing step.

    If it is a file corruption problem that is the root cause, my experience would seem to indicate that a dynamically-created file is the one that is being corrupted, rather than a permanently installed but reusable temp file.

    It could also be that this dynamic file is being closed at the conclusion of the very first scan, but that the Nikon Scan software expects it to remain open at the conclusion of the first scan and throughout all subsequent scans performed during that session. Since ROC and GEM aren't Nikon software, it could be that the mutual interfaces among the software modules aren't correctly specified in their basic design -- meaning that Kodak and Nikon have to work together to solve the issue, if that's the root cause. (A very comforting thought, eh?)

    I've tried other things as well, such as shutting down Norton Anti-Virus and my Norton Personal Firewall to see if that might be a possible cause. No effect.
     
  14. Yeah it really is a nasty bug.
     
  15. Just got a response back from Nikon. They are asking about USB devices on my system and if I'm using the supplied firewire card. I'm using the supplied firewire card, and there are USB devices on my PC, how could you not? Anyway, none are being used when I'm scanning. So, I guess they are thinking it's a communication problem. But, its very strange that it happens on the second scan and not the first.
     
  16. That sounds totally unreasonable. If it were a communications problem, it would not occur during post-processing (unless of course the data was so bad that the algorithm would fail, but that is not the case because we get some good data without the post-processing.)

    My guess would be that it's more likely related to problems with memory allocation.
     
  17. One of the first things the Nikon technician that I worked with in May asked me was, did I have the scanner connected to a USB hub? My answer was no, its connection went directly to a port on the PC. He noted that fact and we went on from there.

    He was not concerned that there were other USB devices connected to my computer, only that the scanner was connected directly to a PC port and not through a hub.

    There is no doubt in my mind that the technician I spoke with in May had a complete understanding of the symptoms and also of the sequence of events of when the problem occurs. He also appeared to know all there was to know about how the Nikon software should normally function and about how the scanner should normally operate.

    One has to wonder if there is any documentation of this problem at all remaining in Nikon's customer support database (I assume they have one) or that someone was working on it in May. Or else the technician you happened to speak with this time around is clueless.

    This problem has all the attributes of a software bug that appears under certain but obviously reproducable conditions.
     
  18. I was skeptical of the problem being communications as well. It may not be a communication problem while the photo info is being transferred. It may be that there is a USB device that is causing an interrupt to be sent to the Nikon Scan software and the Nikon Soft ware is taking a error because it shouldn?t be getting interrupts during the post processing.

    Anyway, I unplugged all my USB devices. The first scan I did received the post processing error. I restarted my PC and the scanner and the problem stopped. I have done about 6 scans so far with the USB devices removed and only the very first one failed.

    I'll post again if the problem reoccurs.
     
  19. Hi,

    It is exactly the same problem with me. Whatever the adjustments are it prompts en error message on XP professionel and SP-2. This is a bug.

    Regards,
    Hakki Uzel
     
  20. I have been chasing this problem for a few weeks now. What I have found is that if NikonView is loaded after NikonScan 4.0.2, then the "...error in post processing" occurs on the second frame when using GEM. Uninstalling NikonView and rebooting make the problem go away.

    Please understand that there may be other applications that cause this problem, including Service packs and hot fixes from MS. I suspect a dll problem, but do not yet have a solid answer.

    I've been in touch with Nikon support, but they have been of no help other than to read the standard tech support script to me about uninstalling and unhooking the scanner and powering it on without an adapter to check for hardware errors. If someone there is looking into this problem, then that person has not yet gotten my information.

    This is not likely a hardware problem, since adding applications and removing them seems to trigger and fix the problem. Windows is known for a syndrome of symptoms arising from DLL-hell - each application wants a version of a dll that is shared among applications, but the version are not compatible. Installation order, installer behaviour, etc all contribute to creating an indefinite state for the software revision of a particular dll.

    It looks like if I want a real answer to this I will have to find it myself. Unfortunately, Nikon seems not to have gotten beyond their software incompetence that I found with their developers 10 years ago when I bought my first Nikon scanner. I guess I should have learned, but the hardware has what I need, including a slide feeder and some decent speed. Too bad it requires software to actually work 8-(.
     
  21. Hi Mark,

    BRAVO! Many people contributed many answers to the GEM problem which occured in exactly the same manner. Only ONE worked. It's YOURS. It works and after uninstalling the View no problems. I hope Nikon officials see this Forum.

    Kindest regards,
    Hakki Uzel
     
  22. Hi Mark,

    BRAVO ! I have seen many contributions to Nikon scanners' GEM problem in many Forums. I understand that it happens as exactly the same way as it is written in previous postings. But, your solution is the ONLY ONE that WORKED. I scanned 36 frames with GEM after uninstalling View without any problems.

    THANK YOU Mark.

    Kindest regards,
    HAKKI UZEL
     
  23. You are quite welcome! Even better news, I now know exactly what the cause of the problem is, and have a fix that allows both programs to co-exist. Maybe if Nikon tech support asks nicely, I'll tell them :cool:.

    The NikonView installer scatters a dll named dragnkl1.dll v 2.0.0.13 in three different places, including \windows\system32. Putting it in that directory means it is found first when NikonScan next loads. Unfortunately, this is downrev from the dll that NikonScan seems to need. NikonScan installs the dll in \windows\twain32\nikon\nikon scan, and it is version 2.0.0.14.

    Copy that version of the dll up into \windows\system32, and all is well. I have noticed some instability with NikonView after this, but there was also instability with NikonScan before this. Nikon tech support did suggest upgrading the dll twain_32.dll from v 1.7.1.0 to v 1.7.1.1. This can be found with a google search from one or more of the websites that try to sell you zip or tech support. I haven't tried that yet, but Nikon tech support did indicate that it was suspect in sombe XP stability problems.
     
  24. I stopped uninstalling View and scanning and then reinstalling View.

    I upgraded dragnkl1.dll to 2.0.0.14
    and twain_32.dll to 1.7.1.1

    And all the problems are in the past. Scanning with all the different settings and View at the same time is possible.

    Mark, thank you very much once again.

    Kindest regards,
    HAKKI UZEL
     
  25. Coolscan V ED with Nikon Scan 4 and update which does not show used on Mac OS 10.3.9
    on either iBook G3 or Power Mac G4, crashes repeatedly (!) when proceeding to SCAN, and
    yes I do use ICE, ROC and GEM. has anyone found a solution what seems to be a bug.

    Thank you, Rina SHERMAN
     
  26. Mike,

    That fix you gave worked like a charm! I'll probably end up uninstalling Nikon View anyway. I have no use for it. All my camera gear is Canon.

    Thanks a bunch for your help.

    Tim Gernert
     
  27. I found a simple solution to the "post processing error" I have a Nikon 4000 Firewire model. I was getting frustrated by this failure as I have about 1000 slides to go in a 6000 slide scanning project.

    If you delete the temp files from the temp file path specified in Nikon Scan, the error goes away.

    Nikon Scan -> EDIT - > Preferences -> File Location

    Make note of the folder path used in FOLDER FOR TEMPORARY DATA. Use windows explorer and browse to this path. Delete all the files in this directory (should be something.tmp). Load up Nikon scan and enjoy.
     
  28. I noticed that the deleting temp files eventually stopped working.

    The second solution I found to this problem was to re-import my settings from Nikon Scan.

    From the scanner window (not the Nikon Scan window) SETTINGS -> Export Settings and provide a meaningful name (this has to be done before the issue occurs.

    When you get the post processing error, click in the scanner window (not the nikon scan window) and click settings import settings and browse to where you exported the settings.

    Start scanning again without issue.

    I noticed prior to performing the import that the file size in the scanner window (not nikon scan) was 42 bytes. After import it is back to the 65MBs I had set it too.
     
  29. syd

    syd

    Well I just bought a 2nd hand Nikon V ED and had exactly the same problem with ROC not running post on my system after preview. I did a search for the problem and tried replacing the Dll's as per the above instructions and so far so good! Huge thanks to Mark Huth ... the system was buggy but now seems fixed.
    Simon.
     
  30. I encountered the error message the original respondent reports, i.e., "There was an error in performing a post processing".
    I was able to clear the condition by going to Scanner->Settings->Reset to Factory Defaults in the Nikon Scan standalone application.
    I'm running Nikon Scan 4.0.2 using a Super Coolscan 5000 ED 1.03 via USB port. PC is running Window SP XP3.
    Since clearing the condition I've scanned two boxes of slides successfully.
     

Share This Page