CF showing pictures from previous photo session

Discussion in 'Canon EOS' started by alexandrutunschi, Jun 12, 2010.

  1. Ever happened this to you? I have a 7D. My 16 Gb Sandisk was formated in camera before the photo session. I shoot raw. After a while the card showed full and I switched t the next card. When I came home at the computer on the card appears the previous photo session and the card is not full. What happened and what can I do to recover the photos? I already tried a recovery program.
  2. It only happened if I select Erase All rather than Format.
    Try Stellar Phoenix Photo Recovery. You have to pay for it. It worked for me. It saved every previously accidentally formatted image on a 2 GB SanDisk CF card. I was able to meet the photo assignments deadline. Otherwise, the accident would have ruined my reputation.
  3. @Peter - I did a full format of this card in camera - not at the computer. I have a card used yesterday that I did an Erase All - and had no problem with it.
  4. I only format the memory cards within the camera. The aforementioned recovery software worked on retrieving the RAW images. I only photograph in RAW and would presume the software will work on recovering everything. The RescuePro software that came with the SanDisk card either would not work or would not recover all the RAW images.
  5. I'd use another card for the next go. That one may be hosed and why risk it happening again?
  6. Thanks, Puppy Face, but that won't recover my photos. I need your input for the problem in hand, not for the future.
    @Peter - that's exactly what I did. I am now at the third rescue program - still trying to find my missing photos. Also, Stellar only finds photos from the previous photo session and the one before that.
  7. I almost hate to ask, but are you sure you've got the right card? Do you keep more than one?
  8. I have 2 CF 16 GB San Disk cards. Both were used yesterday to full capacity. One has the photos, the other doesn't. It's like Twilight Zone - I browsed the photos on my camera, erased the non-keepers from time to time and now I have the photos from the previous session. Not only this, but the recovery programs are only recovering photos from the previous photo session and from the one before that.
  9. Is it possible that you really never formatted the card (I know you said you did) and allow your camera to shoot, even when the card is full? I ask because the logical answer to your problem seems to be that you never recorded any new images onto the card and the card was never formatted and you still have the old pics on there. If none of the recovery programs find your new pics and your camera doesn't either, then they probably weren't there in the first place?
  10. Does the 7D use CF or SD cards? Just curious.
  11. I know your very upset as i would be,i would try to put the CF into the computer you have , i have to use an external usb reader, then I make ISO of all of my cfs when im done at when you make an an ISO of the cf then there is a free program called ISO magic and you can see every file on any ISO no matter what they may be , in the past if you have formatted a cf on anything other than the camera it changes the structure of the disk and it will hide things from you that the camera itself can not see and , the best way to see hidden files is when you make a ISO or basically a snapshot of the memory stick, i can email you the ISO magic if you want.
  12. I'm thinking along the same line as Matt, ie: you've mixed up your cards.
    When I came home at the computer on the card appears the previous photo session and the card is not full​
    How exactly are you viewing the card content? Is it a Windows system? Have a look at the card in Windows Explorer, and check the dates on the files?
  13. Sounds like a problem with the file numbering system on the camera.
  14. Add a third voice to the chorus of Matt... I've never seen a recovery program fail to find at least one photo from a shoot that the card was used for. Especially if the card was filled to capacity during that shoot.
    I have however almost messed up memory cards in the heat of the moment and had I not stopped before hitting format (in camera) and viewed the photos - I would have erased the wedding formals I had just shot and had a card of someone else's wedding safely tucked in my pocket.
    One thought that just occurred to me - did the camera happen to roll over (go from 9999 to 0001) during the session? I had a near panic attack the first time that happened to me - when it happens on a Nikon, the camera also switches the directory that it writes images to.
  15. I would also think, that it is possible that you got the cards mixed up. Maybe you filled the card, thought you had switched it then reformatted. Have you tried to recover anything from the card that is filled as it should be? Maybe(hopefully) you'll find your missing shots.
  16. For what it's worth: maybe you should not go to full capacity on your camera's CF cards. Stop shooting with 8 or 10 images left. The problem may have been the camera was still writing to your card and had no place for the image to go, so the index directory may well be corrupted (or toast.)
    You might try to e-mail SanDisk and see if they can assist.
    Or do a search on Photo Net, one gent (in California) has helped others in getting images off of cards that went downhill....
  17. You don't mention what number image you're on, but when you pass 9999 it starts a new folder and the computer can have a hard time seeing the new folder starting at 0001. Of course, if you Refomatted the CF card, then all old images should be completely gone and your new images (after reformatting) would be all that's left, which is not your case.
    I suspect it's either a bad card, or you somehow thought you reformatted and hit Cancel by accident. Have you tried reformatting another card to make sure there's no issue in the camera?
  18. Thank you for your responses. After a lot of struggle and lots of programs I was able to salvage 40 photos. I suspect that it is something like Jerry Litynski sugested. I did not pass over 9999.
    ISO Magic did not work.
    7D uses CF.
    Thanks for the input and I'll keep you updated with what happens.
  19. Aren't you limited on the number of images you can write to a folder? Once you get to the limit (I think it is 999 on my 5D), you need to create another folder. Maybe this is what happened.

Share This Page