CF (compact flash card) vs Nikon

Discussion in 'Nikon' started by pierre_levasseur, Sep 30, 2007.

  1. I emptied my Sandisk Ultra II 2GB and after that when putting it back in my
    D70s I had this sign on the screen (cha). It seems that my card is out of
    work...is there something to do to make it back to work? thanks
     
  2. You could try and format the card in camera.
     
  3. all my cards are SanDisk Ultra II and they works PERFECTLY in all my cameras, including a D70s I had some time ago.
    As Walter says, try to format the card.
     
  4. I had this exact issue with my D50 and formating the card in the camera did fix it.
     
  5. Forgive me for stating the obvious (well once you know it's obvious), but (as it was pointed out to me several years ago) with Nikons you push two buttons to initiate a format, the trick is that you have to push them, wait for signal (in top lcd) then release and push both again. You'll know your format is successful when the picture count is returned to max. I thought, for the first few weeks of owning my D100, that the camera did some sort of lossless format and that I still had to delete pictures.
    And while I'm at it, formatting is doubly nice because it a) is much faster than deleting images, and b) takes care of any file-system errors that tend to crop up over time. I never delete photos to clear my CF cards anymore, always format.
    Good luck, and happy shooting,
    Greg.
     
  6. Here is what I think happened to you because it happened to me. You bent a pin. CF cards make contact using small delicate pins. They bend easily. I had a camera repair shop bend it back. They charged me for an hour's work which was better than the $3-500 Nikon wanted.

    This happened just days after I bought the camera. I now do not remove my cards. I use the USB only.

    Errol
     
  7. I tried 3 times to format the card but it did not work out. the (cha) is still on the lcd sreen and the non-useable card indication is still on the camera monitor. Anything else I could try? My others cards work perfectly with my camera. thanks
     
  8. I also have a D70 with periodically the same problem. Cards always formatted in camera (actually after every download to PC), no pins bent. This happens to Kingston Elite Pro as well as Sandisk Ultra II.

    When the problem arises, I take the card out, switches the camera off and on again, and the problem is often solved. But the uncertainty is always there.......
     
  9. Hi Pierre,
    I think you're out of luck. This happened with my d70s and an extreme III card. Really stunk. It was my first time using it. There is absolutely nothing wrong with my camera, it was just a dud card. I don't use that card any more, all get is the CHA and "this card cannot be used." I was able to shoot over 200 photos with mine before it failed. No warning or anything. I was pretty bummed...especially because someone's wedding photos were on it! I'm working with a data recovery service now.
     
  10. I too had a similar problem with the same type Sandisk card. Returned it to the company and
    within a qute reasonable span of time I was sent a new card. I think these people are pretty
    easy to work with. I suspect this is about the best you will be able to do.
     

Share This Page