Can't trigger my SL's from my 5D

Discussion in 'Canon EOS' started by ron_brown|6, Mar 14, 2015.

  1. I wonder if someone might be able to help me with a Speedlite problem. I have 2-540EZ's that I use to remotely trigger from my 400D (Rebel xTI). They are just cheap triggers and remote bought off of eBay, but they worked for what I needed them to work for.
    Now I have a 5D original, and I can't get the Lites to fire remotely. I know the SL's and remotes are still working, because I've checked them on the 400D, but they won't remotely fire from my 5D. I don't know if I need to change something in the settings, or these Lites are incompatible with the 5D.
    Any help would be greatly appreciated. Thanks in advance.
  2. I assume that the triggers consist of a transmitter and a receiver and that the flash is triggered from the hotshoe's central contact.
    First question is whether the transmitter has a test button? If so does this trigger the speedlites?
    Do the Speedlites work when mounted directly on the camera?
    If that all works as it should have a look at the custom functions. CF 7 switches the external flash on (0) or off (1).
    Or RTFM as we used to say :)
  3. I agree with Jos. I think the most likely cause of the problem is that CF 7 has external flash disabled. I've used 540-EZs on my 5D for years with and without remote triggers. As Jos suggests the first test of the state of CF 7 is to try firing the flash in the hot shoe. But I will also add that I found several cheap ebay flash trigger to be highly unreliable. I finally bought some better quality stuff.
  4. This is just a thought. As I have bought and used a lot of used gear over the years, the first thing I do when purchasing a new old camera is to give it a thorough exterior clean. I also clean the flash hotshoe contact with a soft-bristled toothbrush and pencil eraser. My Sony A450 and a very battered Panasonic G1 had grimy contacts and worked fine after my cheap Chinese trigger (I think I bought the cheapest set from Amazon!) would not fire.
    So that in addition to what has been suggested by Jos and William.
  5. Thank you Jos, I went into the CF setting and the flash was off. That's what I was looking for. I knew there was a setting, but didn't know what or where. I have fired the flash several times, and it fired every time. Thank you again for your help. Ron

Share This Page