Canon's Digital Photo Professional Keeps Crashing

Discussion in 'Canon EOS' started by steve_brantley|2, Dec 8, 2008.

  1. I am searching for advice about how to troubleshoot Canon's DPP imaging software, which I have come to prefer as my favorite RAW processor for 5D files.
    DPP routinely freezes and then kicks me out whenever I open a new folder of RAW images. Whenever I begin to open a file and watch the thumbnail images start to load on the monitor, an error window suddenly pops open and says something like "Microsoft has encountered a program and needs to close". The program never occurred when I first started to learn DPP months ago, but now it occurs so frequently that I cannot use DPP at all with newer RAW images. I can usually open up older JPEG image folders and review or edit them, but even then, DPP sometimes crashes in the middle of a work flow.
    I have reinstalled the latest version of DPP (version 3.5.1) more than once, and also called Canon customer service several times, with no assistance rendered. Nothing works.
    My review of this problem in the archives of Photo.net, FLickr and other forums gives very little direction, and virtually all of the archived discussions talks about DPP crashing on Apple systems. I can find nothing about Windows being affected, though that is my problem.
    My computer, which runs on Windows XP, has been thoroughly checked for registry errors, viruses, malware, etc., and all is clean. My computer has 2 gig of RAM memory running and plenty of remaining hard drive capacity. The start-up menu has also been cleared of all unnecessary applications that might task the processor of RAM memory. I even turn off my Trend Micro virus/internet security program when I try to use DPP.
    Before I completely give up on DPP, I hope to receive any guidance about how to fix the problem. Thanks in advance for any advice.
     
  2. One idea is to run an extensive memory check with memchk86 from a linux-boot-cd. (Just boot the cd and select memory check from the boot manager). Let that run for a while (a complete checking cycle can take quite a while).
    Also, I googled searched for Dppviewer has encountered a problem and needs to close and found a number of hints regarding an incompatibility of Adobe Elements and DPP. Thats eventually worth reading.
     
  3. I feel your pain and I too prefer to use DPP for processing my RAW files.

    1. XP is a huge memory hog. 2 gig of RAM is not enough when you are processing large RAW files. Add more memory.
    2. Although it is a pain in the rear end, you might think about reinstalling your XP operating system.
    3. Consider the purchase of an iMac. The operating system is much more stable, requires much less memory and DPP runs fine. I have
    been using DPP on my iMac for two years with absolutly no problems. You too can end your Microsoft addiction! :^))

    Good luck!
     
  4. I dump my new files onto a specific directory each time I download my card and I have to admit I have been a bit lazy with this recently. After last downloading my card I went to DPP and it would only show half of my files on the thumbnail view so I presumed it was a memory issue. I transferred some of the files and everything seemed fine after that.
    So maybe it is a memory thing.
     
  5. Hmm, I've used DPP on the Mac since it debuted and it is yet to crash. But, yeah, after I upgraded from 2 to 4GB of RAM the program certainly ran better--faster--so maybe that's part of the problem.
     
  6. I don't really have anything to offer except to say 2 Gb of RAM should be plenty. I run DPP with my 450D files on a PC with only 512Mb of RAM and it's not even slow. I also batch scan 6 frames of 35mm film at a time with a Nikon Coolscan V, which creates 60Mb files for each frame. That does run slow, but it works.
     
  7. Most of us need to run several other programs along with DPP. I usually have PS, DPP and Dreamweaver, Mail & Safari all open at once and bounce files back & forth. 2GB of RAM ain't enough...
     
  8. Regarding the RAM, I am running Vista with only 2 gigs of RAM and it seems to work just fine most of the time. A virus scan can slow it down a lot. The first thing I did when I got the machine was turn off the Windows Search feature that indexes everything on your drive in real time. I don't know if XP started doing that as well but I seam to recall reading something about that (my wifes computer is an XP machine). My current computer will not accept any more RAM, 2 gig is the max and I'm doing OK with that.
    On my wife's XP I occasionally have to turn the Windows Firewall back off. I have a third party firewall but for some reason every few months a Windows Update will turn it back on and the two programs start to conflict, using up more and more resources.
    There's also an updated Codec from Canon for viewing RAW files on an XP machine, you may want to look into seeing if you need that as well.
    In DPP in Tools, General tab, there is a setting for viewing RAW files with moire reduction or High Speed, I'd assume the High Speed setting would use less resources.
    Well that's all I got for now. Let us know when you get it fixed.
    Dan
     
  9. Thanks to everyone for their ideas. After a long telephone call with a very knowledgeable Canon tech support guy, I was advised to uninstall all of my Canon software, and reinstall everything (not from the Canon website, as I had been doing) directly from a Canon EOS Digital Solution Disk. So that is my plan for tonight. Not only is my DPP crashing repeatedly, but ZoomBrowser shows thumbnail images for some folders' JPEG and/or RAW photos, and only shows RAW thumbnails on other folders, but not the JPEGs. So my PC has a few problems with Canon software. Regards.
     
  10. Steve,
    I had this problem when I first got my 40D a year ago. I got the camera, put the CF card in, and started taking pictures. Then I got home and installed all the software on the enclosed disk, DPP, etc. I then downloaded the pictures using Zoom Browser. Went to open the files in DPP, and crash! So after reloading software, etc. I found out what the problem was, and Canon tech didn't even know about it.
    Back up to when I just put the CF card in the camera and started taking pictures! The CF card was not formated in the camera first! So when trying to view using DPP, it didn't recognize the card because it wasn't formatted in the camera first! (My assumption).
     
  11. I had the same problem, with one specific folder containing raw files. DPP would crash whenever I accessed that folder. I finally solved the problem by copying the files to a new folder, and deleting the old folder.
     
  12. This problem has been the bane of my existence ever since I bought my 5D over two years ago.
    I also run XP, with plenty of RAM, a 2.53ghz CPU and a 500 GB HD that's still 40% empty.
    You have no idea how many re-installs, re-starts, unload/reloads, updates and just general maintenance I've done to try and keep DPP from blowing up. I have spent hours on the phone with Canon techs, exchanged god only knows how many e-mail with them, and still the program crashes.
    Why do I do all this when I have CS3 and Bridge? Because DPP is is the simplest way for me to resize batches of images. If I have 10 or 500 images, doesn't seem to matter to DPP how many, I can drop them from 13MB RAW to 500MB jpegs in one shot. But it does seem to matter to DPP when I can't even load a single image without "DPP has encountered and error and needs to close."
    I finally gave up trying to convert RAW files in DPP. I figured maybe if I stuck with Large Jpegs I'd have a better chance. That worked for a while. I got DPP v3.5.2 to stabilize and work almost perfectly. But yesterday, like an idiot, I downloaded and installed v3.6.1, and now it's back to blowing up virtually every time. Sometimes it will load 10 or 15 images before it goes. Sometimes it will open up to the desktop, but as soon as I try to open an image folder it tanks immediately.
    This is nuts. There's no excuse for such a problematic piece of software. I can run CS3, Bridge, Micrografx Picture Publisher, and any number of other graphics programs all day and night, without the hint of a glitch. If the computer starts to slow down I close out and reboot. Fixed. But not with DPP. Doesn't matter what I do or what I try, it crashes. I can even reboot with a cleaned-out msconfig Start-up, nothing else running, and still DPP crashes.
    When the program runs, it's a great tool. But 99% of the time it's a POS. If you can't open it and can't use it, why even keep it around?
    Canon really needs to get a handle on this and find out why the program won't respond. Two years of this mess is more than enough.
    JJ
     
  13. P.S. **There's only one way I can get DPP to work. Process directly from the CF card through my SanDisk card reader. Do that and it works like a champ. Which is fine for an initial run, but once I transfer the RAW and Ljpeg files to the computer and wipe the card I'm back to square one.
    JJ
     
  14. P.S. **There's only one way I can get DPP to work. Process directly from the CF card through my SanDisk card reader. Do that and it works like a champ. Which is fine for an initial run, but once I transfer the RAW and Ljpeg files to the computer and wipe the card I'm back to square one.
    JJ
     
  15. I've recently started having this same problem -- on vista 32bit with 4 gig ram. I'm hoping my case can also be solved by copying what appears to be the problem folder into a new one.
     
  16. Did anyone solve the problem? My first guess is that DPP has problems to handle folders on the HDD with a certain amount of RAW images or a big total file size. It's a shame they weren't able to fix this problem in all this time...
     
  17. I have made some progress on this problem. I have found out that, with some help from a member over at Digital Photography Review, DPP has had problems in the past with picture files that were modified by other programs. So I downloaded 'virgin' files from the card into a new folder and DPP worked perfectly on that folder, where before it would consistently crash on folders that had modified files.
    In my case, the program that I used to edit the pictures is Smart Pix Manager. I don't know if other programs will exhibit the same behavior. I opened and edited a picture in PSE7 and saved it, and DPP did not have a problem with that.
    Maybe this will get someone else pointed in the right direction.
     
  18. I bought a Canon 40d last year.
    I switched to MAC and have a MBP under OS X 10.6.1
    Now I have problems with Download the Updates.
    info says "problem with Updater" and the process stopped. So I can not use DPP, EOS utility etc. (The software can be installed from CD, but not the updates!)
     
  19. I am getting frustrated to all ends. I have CS3 which will not read the new RAW format with my 5DMark II and the Digital Photo Professional just keeps crashing when you open the damn folder.
    Has anyone got this resolved. I really do not want to purchase CS4 at this time just to use a Canon supplied with software you can't use.
    I have an awsome rocking system so the space and memory is not the issue here.
     
  20. I have realised it is a particular photo that is causing my digital photo professionalto crash. So the solution is basicall to move the .CR2 raw file to other folder and then maybe use photoshop or others to edit that particular photo.
     

Share This Page