Canonet QL17 Shutter Won't Fire

Discussion in 'Classic Manual Cameras' started by davecaz, May 9, 2018.

  1. Hi,

    I just received a Canonet QL17 G-III in very nice cosmetic condition, but I bought it "untested", and the shutter doesn't seem to want to fire. I can cock it, I think, with the film advance lever, but pressing the shutter button does not cause anything to happen.

    I'm hoping there's a step I'm missing or a switch that needs to be set (although I don't see any). Anyone know what the magic solution might be?

    Thanks!
     
  2. Well, I've now seen a couple of threads here about this subject. Don't know why Google could find them, but the built-in search couldn't. Anyway, I'm guessing it's the dried up lubricant problem, I've seen two approaches mentioned. One is to remove the back lens elements through the film door. Not wild about that one, especially as it begins with building my own tools.

    The other is to drip naptha/ronsonol into the self-timer slot. That I can handle. It seems like it might be a good idea, anyway, because the self-timer lever won't budge, either. So, I'll give that a try and let you know how it goes.

    Sorry for yet another thread on a recurring topic.
     
  3. I am assuming that you have a fresh battery installed. Does the battery check work? Is the meter needle moving? If the needle is in one of the red areas above or below the scale in the viewfinder the shutter will not work. Adjust the exposure until the needle is out of the red area and the shutter should work.
     
  4. If you take the aperture off of "A" and place it to any f stop setting (essentially manual mode), the shutter should fire. This should work with or without a battery. Also, what Robert said above is correct. In auto exposure mode ("A" on aperture ring), the meter needs to be working and exposure needle needs to be out of the red areas, which represent under and over exposure. The camera has only shutter priority AE, so that you adjust the shutter speed and the camera selects the aperture (as long as the aperture is within what is available (f 1.7 - f22).
     
  5. No, the battery is stone dead, but I didn't worry about that because, as you said, it should be able to trigger the shutter without the battery.
    I'll be darned. I know I tried that during my efforts to get it working but, sure enough, when I checked, it was on A again. Moving it off A worked, this time. And, surprise, surprise, it triggered the self-timer. So, apparently, it was stuck and my dosing it with naptha actually did do some good.

    It's still not performing well, though. If I close the aperture down to f/16, the blades close easily enough. But, when I open it back up to f/1.7, the blades don't actually move until I've fired it several times. Then it gradually creeps open a little more with each shot. Somewhere around the 20th shot, it looks like it's wide open, again. It's a very strange experience to see the aperture move all by itself with each shot. Maybe, with enough exercise, it will free itself up. Or maybe I should give it some more naptha.

    Thanks, Robert and Ken, for your help.
     
  6. Please be careful with the Naphta.. your current problem may already be the result of the naphta. The naphta dissolves lubricants and they wander about and foul the aperture blades and may have fouled the shutter escapements causing the problems you now have. The scenario you've described seems to be that the timer was stuck. This would give the impression you described, as not firing...even in manual mode. Now that the selftimer at last made it's problem known and has finished it's cycle successfully, the dissolved lubricant is causing the current problem.
     
  7. Thanks, Chuck. I've been thinking that, if repeated firing of the shutter doesn't loosen it up, either the QL17 becomes a shelf queen or it goes to a pro for a CLA. And, it doesn't seem as though it's going to loosen up. I've probably fired it close to 100 times, and it's not improving. It fires, and the speeds vary with the setting I choose, but there is a long-ish hesitation before the shutter blades really begin to open.
     
  8. Based on my (limited in terms of success) experience: it's Ronsonol and firing, Ronsonol and firing, Ronsonol and firing... as long as your patience will allow. In a particularly stubborn case, I left the camera with its front part submerged in Ronsonol up to the ST slot level for 24 hours. While it is true that you should be careful with Ronsonol, the only real problem this may cause in a QL17 is a deposit on the lens, either on the aft surface on the front element or the front surface on the aft one. Fortunately this can be cleaned relatively easily (even by a two-left-hands individual like myself) by removing the front element (it's better to leave the aft one alone). Instructions for doing so are easily available online.
     
    davecaz likes this.
  9. I appreciate the input, bonsignore_ezio. What would you say your success rate has been, using the ronsinol-fire-repeat method? And, are you talking about standing the camera on its filter ring in a bowl of Ronsinol?
     
  10. Does there need to be film in the camera to release the double exposure prevention system lock? Try turning the toothed spindle manually to simulate film advancing and try it. Good luck.
     
  11. @davecaz: I have been able to use the Ronsonol/fire/Ronsonol/fire etc method to bring to (apparent) working conditions all the jammed QL17s I applied it to (some 20+), unless of course there was something broken in the shutter linkage. In about half the cases, however, this only lasted for a certain period (days or weeks), after which the camera jammed again and the procedure had to be repeated anew.

    Summing up: the "Ronsonol cure" is most certainly NOT a replacement for a proper CLA (including completely dismantling the shutter and cleaning its blades) by a competent repairman. It is but a desperate shortcut for people like myself who a) are unwilling to disbourse 3-5 times the purchase prince of the camera for a repair, and b) are not skilled or patient enough to perform the CLA themselves.

    Yes, I meant exactly that: the camera on its filter ring on a bowl of Ronsonol. Please note, however, that this is a MOST desperate procedure, in that it is likely to remove all the writings on the aperture, speed and focus rings. These are not simply painted but also slightly carved into the metal and thus can be restored with a rather simple procedure, but this is an additional problem you would rather wish to avoid. I went to those extremes (on a camera that was a junk cosmetically, and which I had purchased for the specific purpose of experimenting), just to see exactly what was possible to do with Ronsonol.
     
  12. Absolutely. Although I am known as the "Lord Naphtha, King of the Petroleum Wastes," the amounts of the solvent (any solvent for that matter) involved in such things should be tiny, really less than you'd think possible. Tiny amounts and working the part, and only for parts where you can see where the solvent is going.
    Flooding is almost never advisable.
     
  13. I had no idea we were in the presence of royalty. :) How came you to be so dubbed?
     
  14. I have lots of words and some people are saying that:rolleyes:


    I've been using naphtha cautiously for years to unstick cranky old East German cameras
     
  15. Hi JDM. I have one if these too and the aperture works well, but the shutter is sluggish. When I press it, it will fire after 1 to 4 seconds. I can see the blades moving slowly. A local workshop quote me a rather high price to fix it (actually they declined at first, then, with my insistance they did quote...) Do you have any suggestion ? Thank you.
     
  16. Hey DAvecaz,

    I see youR'e still at it. a partial strip down and careful application with qtips and ronsol/fire etc could work. 'I'm not against desperate measures.. but what will you have in the end. I think the other poster said.. he was experimenting to see how far to go. I think I would consider this "immersion" method with a shutter I could remove like on a folder or a TLR where fewer glass surfaces come into play... Again partial dis assembly might be recommended to achieve the dunking or baptism effect.
    I have his model (my brother gave me his) and and with mine the shutter has not been a problem. initially the film advance was gunked up from the deteriorating seals. Amazingly it started working when I was ready to give up on it. The meter never worked. Sadly I don't have an eveready case and though I am always careful this baby has hit the floor twice; the first time it landed on the back corner and the door just needed a little coaxing and it was fine. the most recent time ...it slid from the open cabinet and landed on the lens badly denting the beauty ring ( no longer beautiful) At first I thought it was just ugly, but the shutter aperture dial is way too stiff. I took the dent out and now I can adjust the settings a little easier ..but you could say it's f--ked. You may also be able to say the same thing in the end... but I understand your very well your tenacity!!
     
  17. My suggestion would be to find another repairman. If you had to force them to quote you, I wouldn't trust their work.
    Well, it's partly because I was hoping to use the QL17, and partly because I used to have much better luck with my purchases. Whatever I bought online, assuming I had checked the photos carefully, would show up in at least as good condition as I expected, and I rarely got a problem. Now, I've had a whole string of disappointments.

    That's only to be expected, I guess, but my previous history conditioned me to be less cautious than I probably should. I paid $40, plus shipping, for the QL17. Not a lot, if it worked, but not the $5-10 I keep seeing people post about. And it doesn't make sense to put another $150 into repairing it.

    Also, people keep replying to the thread. :)
    Dave
     
  18. Guys, great news ! I put the camera in the sun for a few hours and started firing as it warmed up. Eventually it started working again. I played with it for quite a while (again and again for several hours) and it works again now as it should !!! Actually I'm quite surprised, but we'll have to see after a couple of days if the fix is permanent or not. The repair man's quote was about $ 110 (converted from our local currency) to fix the shutter and clean the viewfinder... They said to get another one would be cheaper, but there are not so many around here...
     

Share This Page