Canon QL17 GIII not firing

Discussion in 'Classic Manual Cameras' started by leicaglow, Sep 15, 2009.

  1. I may have purchase a flea off of fleabay. Really nice QL17, but the shutter doesn't fire. I have it on manual, not Auto. I shouldn't need film in the camera to make it click should I? Anything obvious I might be missing? It seems to wind, but I can't get the shutter to fire. Also, when winding, there is very little resistance (granted there is no film in the camera), but it doesn't feel quite right. Any ideas?
     
  2. I suspect that your Canon is suffering from a case of dried out or congealed shutter lubricant. The last of the GIII Canon's were produced in 1982. If yours hasn't been CLA'd (cleaned, lubed, adjusted), then yours is due for this service. For about $100, your Canon can be disassembled, light seals replaced, viewfinder cleaned, shutter speeds tested and timed and viewfinder cleaned for optimum brightness for ease of focus.
    I own a vintage 1965 Canon QL19, the earlier model, not the smaller version you have. I had mine CLA'd and it now works beautifully. Although I stockpiled some PX625 Mercury cells years ago, stored in my fridge, I don't bother with the battery for the meter. I load up with Kodak Tri-x 400 or TMAX 400 and just use the classic sunny f16 rule..
    These are great cameras to use, your model even more so because it is a bit smaller than the earlier Canonets. Yours is equipped with a 6 element, 4 group lens. Some of the elements used in the lens are rare earth glasses (somewhat exotic). Once the shutter is properly timed and your viewfinder cleaned, you will be amazed at the results you will get with print film. If you shoot with slide film, then I'd recommend both a hand held meter and the built in CdS meter in your Canon..
    Load up....focus...shoot..and enjoy!
     
    ] likes this.
  3. Michael, normally I would agree that the shutter blades are stuck (a job you could do yourself if at all mechanically inclined)but, if the shutter doesn't fire you should not be able to advance the lever. Since this is the case I would definitely have it looked at by a pro, or if it's not too late, send it back for a refund.
     
  4. The QL17 GIII that I have does not need film in it to make the shutter trip. I did notice that the shutter is incredibly quiet though.
    When you say it seems to wind, have you tried operating it with the back open to confirm that the advancing mechanism is moving when you operate the lever? When you press the shutter release, is there any sound at all? Any change in the resistance as you press it?
     
  5. At least the lower end Canonet models won't fire unless the exposure is in the range of possibilities. Have you tried it outside in the sun? Otherwise, as people say above.
     
  6. JDM, that would't effect the 17 GIII unless in auto mode, it should fire in the manual mode regardless of exposure settings. Unlike the 28 which is auto only.
     
    ] likes this.
  7. DOH! Double posted again!
     
  8. Tom's assessment is not quite correct: the most common cause of a GIII not firing is the shutter blades being glued together with dried lubricant. When you press the shutter release, you hear nothing, but then you can wind the lever on and do it again. The reason why the wind lever didn't stay locked up is that the shutter thinks it fired - the mechanism was tripped, the blades just didn't move. The fix for this is to remove the front lens cell, unstick the blades by prying the top one up very slightly with the point of a sewing needle (if you've released it, the shutter will fire instantly as you lift the top blade), and then cleaning off the surface of the blades with cigarette lighter fuel on a cotton swab.
    There are other, more complicated possible causes of a similar condition, but I'll put my money on this one.
    There is a tutorial for this DIY repair at http://www.kyphoto.com/classics/canonetblade.html
     
    ] and ralf_j. like this.
  9. On the QL17 the winding lever should provide a fair amount of resistance when winding. I suspect the winding mechanism of your camera is somehow disengaged from the shutter cocking mechanism. This has happened on some of the fixed lens leaf shutter rangefinders that I own.
     
  10. i have handled a number of ql17's that have both reluctant aperture blades and non-firing or erratic firing shutters--these seem to be their most common issues.
    the shutter not working could be dried lubricants as stated but more commonly what i see is that repair has been attempted to free up the aperture blades and the lens was not remounted properly during disassembly. this is very easy to do as the compact lens assembly is very delicate and each part needs to be rotated to fit at precise degree. the cocking mechanism cannot engage and this essentially locks the shutter. i really don't recall the details of correcting this as i decided these cameras are too complicated for my liking and passed a project one to a friend.
    i just wanted to point out another possibility of what the problem could be.
    of course if you're not going to attempt repair, getting a professional to CLA it will give you a great little camera.
     
  11. Thank you all for your great advice. Because I'm the type of person who tries to fix things, then ends up with extra screws and washers, I'm heeding my own advice and have sent it off to Advanced Camera for a CLA. I'll let you know how it turns out. I'm hoping for the best because the camera is in beautiful shape, and I love the focusing and handling.
     
  12. I have quite a few (17) Canonet G-III cameras with the shutter problems in the past. The solvent cleaning theory really works well with all the lenses removed. I also have two more that have a different shutter problem. The shutters were cleaned although there is a deeper problem inside the mechcanics that will not allow the shutter to open. I am uncertain if I should do a complete tear down since these are so intracate.
    Any suggestions?
    Thank you
    00UgnP-178799584.jpg
     
  13. Well here we are 13 years later and now I am tearing down my defective shutters. After completion I will post my findings on the problem(s)
     
    ] and Julio Fernandez like this.
  14. In a GIII with the "shutter not opening problem" that I tried in vain to repair, the culprit was not the shutter itself but rather the lever that transfers mouvement from the release button to the shutter. This piece was broken, and the disassembly work required to remove it was way beyoind me - further, I had no replacement piece.
     
  15. My first one had an egged-out shutter pawl that had to be replaced. Now it is working once again. My other one will be stripped for parts since that one has many internal problems
     
  16. I got lucky since I had a spare shutter for the needed part. Yes, tearing one down is a chore to any novice. I dig into this type of shutter once in a while to keep my sanity
     

Share This Page

1111