Canon FD 28 mm f2.8 Diaphragm Problem

Discussion in 'Canon FD' started by christianlonghi, Apr 1, 2020.

  1. Hi everyone.
    I got this lens that have a problem: from an aperture of f22 to f11 (there are 5 stops moving the ring on the lens) actually the diaphragm doesn’t move, is stuck at f22. After that each stops it move correctly.
    I can’t understand what could be the problem and I've already disassembled 2 times the lens.
     
  2. The old joke is that if you disassemble three times you will have enough left over parts to build a new one.

    FD lenses often had the minimum aperture setting as 'A' for automatic exposure? That's not what you are talking about is it?
     
  3. Haha yeah! Thanks for the reply.
    No, I know what you mean though.
    I'm meaning in manual mode, if I move from f22 to f11 there is no change in the diaphragm size but from f11 to 2.8 it opens as it should?
     
  4. Do you see any lube on the aperture blades? That would cause the blades to stick.
     
  5. Unfortunately not, I already cleaned the blades. They move free and smooth.
     
  6. You haven't mentioned if you're using this lens on a matching Canon FD film camera (AE-1, etc), or with an adapter for a digital SLR or mirrorless body. That info might help a more geeky Canon user narrow down the problem for you.

    Some long shot ideas:

    Mounted on an FD film body, with the shutter set to B or a long speed like 1 sec, when looking thru the opened back of the camera thru the shutter, when fired the lens should stop down correctly to whatever aperture you've set on the ring (with the camera set to manual exposure mode). If so, the lens is OK (its normal if it only works right when on camera, off camera is often no-go). If the lens is not stopping down properly on an FD body, something is jammed or broken: you may have re-assembled it slightly incorrectly, some hidden part may have been defective or sticky all along, or a tiny part may have fallen out and gone missing.

    If using this 28mm with an adapter on a non-FD body, unexpected weirdness can sometimes occur. The mechanical camera body > lens diaphragm interface in the mount of FD lenses is peculiar compared to similar-era Nikon, Minolta, or Pentax lenses, in that the lens aperture sometimes won't operate unless its mounted on an FD camera (off camera, spinning the aperture ring does nothing, on camera, it works normally). Assuming you did completely fix the original aperture issue and re-assembled the lens perfectly, you might additionally need to "enable" off-FD-camera manual control of the aperture before it will actually respond to the ring for use with a non-FD body. This trips up some of us because almost no other vintage camera/lens aperture connection works that way. If enabling manual control (via the youTube instructional video link below) doesn't solve the issue, JDMvW may be right that "three times (disassembly) is the cure", or the lens needs professional service to replace a missing/damaged part.

     
    Last edited: Apr 2, 2020
  7. Hi Orsetto, thank you for Your reply. I am using a Canon AE-1. Actually I’ve already checked what you told me and even I already did what the video shows. I will upload a video in a few minutes where actually explain what is the problem so everyone can understand better. I might post a link to the video. Probably I will upload it to YouTube and here I will post the link.

    thanks to everyone that is trying to help me
     
  8. here we go, I post here the link of the video. I hope will help to understand better the problem.


     
  9. Beautiful black AE-1, very nice! I just noticed in your other thread about the camera body that you had an issue with the shutter speeds, solved by a cleaning. There's a chance the aperture actuator mechanism is also in need of cleaning: perhaps its strong enough to operate your other FD lenses correctly, but sticks on this random 28mm example.

    Otherwise, no idea what could be causing this specific aperture hangup, unless something has not been re-assembled 100% perfectly or is still a bit gummy after you cleaned it. It is not uncommon for aperture ring controls to be partially functional like this if the lens mechanism has been re-assembled slightly off: even my very simple old Nikkor lenses occasionally behaved like your video if I made a tiny mistake, forcing me to open up and re-assemble, adjusting the mount position and aperture lever / diaphragm linkage just so until everything moves thru entire range properly.

    This could be a little bit more difficult with FD lenses due to the more complicated mount mechanics with the hidden aperture interlocks (Nikon, Minolta, Pentax just have the aperture lever, pin or plate to deal with). Maybe put the lens aside for a few days, then when you feel in the mood to take it apart again, go slowly and see if you notice anything a hair off. Adjust the fit at that point, and you may solve the issue. I have a strong feeling JDMvW will prove correct that one more try will get it back in order (but hopefully not another total disassembly) . Good luck!
     
    Last edited: Apr 2, 2020
  10. SCL

    SCL

    Viewed your video and I clearly see the diaphragm change until around f/11 when you have the camera in the bulb mode. When you actually fire the shutter (say 1 sec) for each f stop does the diaphragm operate the same way, ie, ok from wide open until f/11? If it does still exhibit the issue then I'd agree with Orsetto, that there may be a small maladjustment in your reassembly. If it works ok, I'd forget about it until a later time. In this case it may merely be an untensioned spring which will self readjust with use.
     
  11. Thank you so much! I will try to give it another try :) I wish I can find another lens like mine that works so I can disassemble it and step by step compare how is inside... I tried to check online but seems that there aren’t video, photos or manuals about it... Anyone has any website/place/book where maybe I can find it?
     
  12. Here are three "Canon new-FD" videos I would suggest looking at (if you haven't already seen them). None is specific to your 28mm, but that lens was part of the same construction subgroup as the 50mm f/1.8 which is typically used as the example for such videos, so anything regarding the diaphragm should apply universally. Several comments appended to these videos are from people who did use the info to successfully repair their 28mm f/2.8. The first is a shorter tutorial on "gotchas" to look out for when putting the lens back together, the second is a bit more detailed, the third is a comprehensive guide to the FDn aperture mechanism from one of the most thorough repair gurus on youTube (mikenon62 is my hero).





     
  13. cmuseum

    cmuseum cmuseum

    Here are some images of a New FD 28mm 1:2.8 (S/N 56xxxx range) with the mount removed:

    Aperture ring set to 2.8:
    f2.8.JPG

    Aperture ring set to 11:
    f11.JPG

    Aperture ring set to 22:
    f22.JPG

    Aperture ring set to A:
    fA.JPG

    Incorrect setting (lug of inner aperture ring does not match notch of outer aperture ring), don't assemble this way:
    incorrect.JPG

    Try the same configurations with your lens and compare. Pay attention to the position of the outer aperture ring, the inner aperture ring, the cam ring and the small lever actuating the aperture blades (11 o'clock position).

    • The outer and inner aperture rings are linked by a lug (3 o'clock position in first picture) that can slide up and down while the mount is removed. It tends to disengage, watch out for it.
    • The inner aperture ring and the cam ring are unlinked while the mount is removed. Look at the inside of the mount and you will immediately see what part fits the lug of the cam ring. Make sure they are match properly when reinstalling the mount.
    • The small lever should always be touching the cam ring. If it is not, check diaphragm unit (again).
     
  14. Thank you so much for your answers guys!
    I tried to disassemble and reassemble the FD 28mm but the problem is still there.
    I attach below the photos for each aperture so you can understand better my problem. As you can see the aperture at f22 and f16 are the same.
    Aperture ring set to 22
    IMG_0242.JPG
    Aperture ring set to 16
    IMG_0243.JPG
    Aperture ring set to 11
    IMG_0244.JPG
    Aperture ring set to 8
    IMG_0245.JPG
    Aperture ring set to 5.6
    IMG_0246.JPG
    Aperture ring set to 4
    IMG_0247.JPG
    Aperture ring set to 2.8
    IMG_0248.JPG
    Aperture ring set to A
    IMG_0249.JPG
    And this photo shows how I assembled the lens
    IMG_0250.JPG
    If you can take a photo for each aperture maybe I can compare with mine.
    Thank you so much
     
  15. cmuseum

    cmuseum cmuseum

    Position of the aperture signal lever matches the selected aperture value. That makes me think the mount was correctly assembled.

    My next step would be removing and inspecting the diaphragm unit (again).
     

Share This Page