Canon EOS Rebel S malfunction

Discussion in 'Modern Film Cameras' started by spmc, Mar 1, 2020.

  1. Hello- I'm figuring this thing is bricked but I'll put it out there in case someone else has encountered it and knows some trick to resolve.

    I scored a Canon EOS Rebel S as a package deal with an old Zeiss Ikon medium format folder at swap meet for $30 yesterday. I figured for the combined price, the EOS was at worst a decent brick on a strap for self defense. I got a battery for it and, hurray(!), it worked -- for about an hour...

    I was going through the users manual, fiddling with the various modes and settings and dry firing the shutter when the mirror hung up halfway through the return stroke. The dead battery symbol was blinking and I could hear the motor trying to move when I pushed the shutter button. With some gentle pressure on the mirror, I could feel it move a little every time the button was pushed until eventually the mirror swung all the way down. The LCD now shows the correct battery level and relevant shutter, aperture and exposure comp scale for the various mode selections. However, now when I engage the shutter button, the mirror flips up and stays there and the dead battery symbol blinks on the LCD. If I push the button again, the motor engages and re-cocks the mirror and the LCD shows the expected info again.
    • I've confirmed that the shutter doesn't actuate during any of this.
    • The the shutter, aperture and exposure comp stuff will appear in the viewfinder unless the flash is flipped up
    • The autofocus no longer works
    It seems like this is some kind of software glitch. The Rebel only has one motor that drives all of the motor controlled functions sequentially through geared transmissions. It's like the command or signal to fire the shutter never happens so the rest (mirror, re-cock and film advance don't follow. I loaded some film to see if it actually would load, and if it did, maybe that would maybe reset things. The film loaded fine but no change the camera functionality.

    Anyway, like I said, this thing is probably a brick but I thought I'd ask.
     
  2. William Michael

    William Michael Moderator Staff Member

    I am reasonably confident in my memory of that Canon era: there are two reasons why the battery symbol will BLINK:

    1. The battery is close to end of its life - i.e. it's an "early warning" for you to replace the battery
    2. There is a camera malfunction

    If you have confirmed that the battery is new, (i.e. a fully charged non-compromised battery) and the battery terminals (both camera and battery) are clean and dry, then I am reasonably confident that you'll find there is a fault with the camera.

    WW
     

Share This Page