Canon AE-1 Shutter Problem

Discussion in 'Canon FD' started by jonpaul_hills, Aug 29, 2011.

  1. I have a Canon AE-1 film camera, and the shutter will not fire. When I received the camera, I advanced the film advance lever, and everything appeared to work fine. The shutter moved to the left, and the film winder spun. But when I press the shutter release button, nothing happens. The button still depresses, but the shutter will not fire, and the mirror doesn't move at all. The film advance lever doesn't move, since the entire shutter is over to the side. The light meter works, and I put a brand new battery in it, which I was advised may fix the problem, but alas it did not. I just wondered if anybody knew what the problem may be, and what it would cost to fix, or if it is something very simple that I could just pop the top off the camera and fix myself.
  2. awahlster

    awahlster Moderator

    OH MY do not take the top off the camera to do so without the repair manual (of which there really is none) or at the very least the presettings for the shutter and meter in hand you might as well throw the thing in the trash. Very very few good repair techs will touch a camera that has been messed with and the AE-1 is a boobie trap waiting to spring if you take it apart and don't know what you are doing.
    That said where are you and your camera located and maybe someone here knows a repair shop close by that can do a Clean Lube and Adjust (60-120.00) which will normally fix any minor problems.
    Nothing inside a Canon AE-1 is simple.
  3. I live in Fremont Michigan, which is about an hour south of Grand Rapids. I Know of a couple shops, but I have no idea of how well they work with old cameras.
  4. awahlster

    awahlster Moderator

    Call them ask them any shop that has been in business more then 5-10 years has worked on Canon AE-1's they were one of the best selling SLR's of all time.
  5. Ok. Thanks.
  6. Sounds very much like a combination magnet which I suggested in reply to your earlier post.
    It's down at the bottom, but like Mark I don't recommend that you try to tackle this on your own. There are at least two good manuals, one from SPT, and one from National Camera in a three part series in Camera Craftsman on the AE-1. But you'll have more than the cost of repair locked up in getting the reprints and the tools you might need (an oscilloscope, etc.). And if it's your first repair you will likely fail. Just the statistical probability, not you personally.
    Some here have found this site helpful and recommend it:
    I have absolutely no experience with them and am just passing it along. Any camera repair facility you find should be able to deal with an AE-1 as Canon made millions of them. They are good cameras and worth fixing.
  7. I took the bottom of the camera off last night, and fiddled with some of the wires on the little plastic circuit board to the left of the MG2 magnet, then it worked! I didn't actually do anything, i just moved the wires a little. But when I tried to move them to clean the connections of corrosion, it caused the camera to stop working again. I could not get it to happen again, so I'm assuming that it's something to do with those wires, maybe one is broken inside or something is corroded to the point of not working.
  8. As you have bitten the bullet and removed the bottom, let me add a suggestion. I fixed my A1 which seems to have an identical mechanism by referring to 'Andrew K's' method on the second of these two pages:
    and cleaning the magnet faces with lighter fluid. I was very skeptical that this would work, but it did. One year later it's still going strong. I didn't remove the plastic cover, but cut it and bent it back slightly. I'd give this a go before unsoldering any wires.

Share This Page