Canon A-1 display EEEE EE

Discussion in 'Canon FD' started by c_zaz, Nov 8, 2002.

  1. I recently bought a used A-1, which has a problem. When you try to
    press down the shutter button you get EEEE EE display in the view
    finder.
    I tried fixing it the way it says in the manual with the stopped-down
    lever but it didn't work. I am still getting the error message and I
    can't get it to take a picture. I am doing this without film in the
    camera.
    Any one know what else could be causing this and how to fix it?
     
  2. Try using the multi-exposure lever. Push it to the left, then cock the shutter, usually works for me...
     
  3. I first encountered that problem 20 years ago with my A-1 (which I still have and use), and Mark's tip does indeed fix the problem.
     
  4. I believe the procedure to which Marc refers is the one the original author claims to have tried (the procedure in the manual to flip the multiple exposure switch, then cock the shutter). If this does not clear up the problem, there could be a problem with the camera. I had a similar problem with an A-1, and the simple procedure outlined in the manual is designed to clear some error path in the camera logic that results from stopping down the lens, then not actually taking a photo. One thing to try would be to install any FD lens, take it off of the "A" setting, and see if the camera responds correctly (meter displays correctly, shutter releases, etc.). If this is the case, your camera probably has the same problem mine did, which was with a micro-switch inside the camera that senses a subtle movement of the aperature lever on the lens when the lens is set to "A." The switch has numerous circuit paths on it, and one or more of them may have a failure or some other break in the circuit. Replacement of this micro-switch should restore full function of the camera. The repair was around $100 or so (parts & labor) for me at my local shop.
     

Share This Page