Canon 580ex II misfiring

Discussion in 'Wedding and Event' started by sandra_falksen, May 12, 2010.

  1. I'm shooting a Canon 7D. I have the canon flash 580ex and 580exii. Since I have had the newer flash I have used it almost exclusively. I don't remember having this problem with 5D or 30D, but now I have it with the 7D and 5DmkII. The flash misfires. I'll be shooting along with it connected to a Quantum Turbo battery and taking pictures and then several pictures will be taken without the flash firing and then it may fire one or two in between the misfires. I have bought new cables. Used the other Quantum Turbo with same results. Today I used the 7D with my 580ex not the exii and it worked fine. Question: Is there some setting on the 580ex ii that I need to change (didn't see anything in the book) or is my flash needing repair or replacement? Thanks for any help.
  2. Make sure the contacts on your flash & camera are clean. I would sometimes grab hold of the flash and the oil from my hand would interfere with firing. Thought I would pass this on to you as a possible cause.
  3. How quickly are you tripping the shutter..........are you giving the unit time to re-cycle?
  4. Thanks all of you. I will read the two links and I will give these a try. As a said, I used the older 580ex in the same manner and it worked. I don't think I am shooting faster than the flash can recycle. I would think that it would perform as well as the 580ex. I appreciate the help. I was running out of variables.
  5. From what you said I figure it is one of several things.
    1) The Turbo is not being hooked up as specified, therefore, the external battery is not being drawn from at all. Meaning, the flash continues to use the AAs, running them down, and you are getting misfires because the flash is not recycling fast enough. Or the flash is going to sleep.
    2) Since the behavior is with the 7D, the fit between the 580EXII, with the rubber collar around the hotshoe foot isn't great. This is a known problem with the 580EXII. The contact between the two is compromised, and the flash goes into TTL mode, not ETTL (watch the LCD). When it goes into TTL mode, it fires full power, meaning your recycling is longer (3 seconds without the battery pack, which, if it isn't being drawn from...). Sometimes cleaning contacts works, as well as ensuring a good lock down of the flash onto the hotshoe.
    3) It could possibly be that your camera's hotshoe plate is loose. Probably not since your 580EX seems to work OK. But I'd check it anyway.
    4) The 580EXII has a thermal cut off switch. Read the manual, as described in the thread. If you fire a string of flashes at or near full power, the flash will slow the recycling down considerably, and/or shut off. So your misfires could be the flash slowing the recycling down. On another note, you may what to set your custom function for the flash to use the external pack only. If using both the pack and the AAs, and if your AAs are weak or getting weak, you will not realize the benefit of the pack recycling speed.

Share This Page