camera won't take photo's

Discussion in 'Canon EOS' started by ronald_pruitt, Oct 21, 2009.

  1. I have a tried everything I know but nothing has helped. When I try to take a photograph, press the shutter release button, a 9 with a green flashing light shows up in the bottom of the view finder and the camera will not trip the shutter. I've tried resetting the camera's setting, I replaced the battery and have turned the camera on and off several times. Any suggestions?
     
  2. Hard to diagnose such an issue here, but the last time I had a similar thing happen the camera needed to go to Canon for repair.
    If you remove the lens and look into the chamber is the shutter open or closed?
    Dan
     
  3. closed, and it does take a picture occasionally, but then seems to stop again. Even when it does take a picture it acts as if the self timer is on, but I've checked and even gone through the process of making sure it is off.
     
  4. after further checking, I think the problem is in the lens. when I switch the lens to manual focus it seems to work fine, but the lighted 9 still appears in the view finder.
     
  5. did you try another lens?
    try to take out the battery and the clock battery and then restart the camera ..and you have reset the time too.
    make sure you try to go back to factory setting.
    did you search the error notice you are getting?
    if all fails call canon for further help
     
  6. It might help if you let people know which camera and lens you are talking about. :)
     
  7. Not sure what type of camera you are talking about, but a green flashing sign on a Canon DSLR usually means that you haven't focused correctly. The camera then locks the shutter.
     
  8. Sorry for the omission, the camera is a canon XTi (400D).
     
  9. I'll bet the "9" is just the number of shots left in your buffer. It means you can shoot 9 pictures in a row in continuous mode before you have to stop.
    Is the lens attempting to auto-focus? The blinking green means "no focus" and it won't shoot unless you find focus first. If the lens is not attempting to focus, then the lens is broken.
     
  10. Yes before a repair, check it out to see that you don't have it set so it can't take a picture. Make sure the light is enough to focus, put the camera on P, and see if it works. If, for example, you've set the camera so it is faced with some sort of impossibility, it will refuse to function.
     
  11. What JDM said.
    The 9 i sjust the buffer size - ignore that.
    Aim the camera at a bright contrasty item. Then focus, wait, and when you hear the beep, click through.
    If you aim at a blank wall, the beep will never happen, and you will never be able to take the picture.
    It can help to select ONE focus spot, and to aim THAT focus spot at a contrasty item.
     
  12. It sounds as if your lens is having difficulty in focusing. Turn it to manual and see if that makes any difference.
     
  13. I had the same problem with a Nikon and a Tokina 35mm F2.8 Macro lens. As it turned out, if the camera can't focus on a blank object, such as a wall, it will not snap a picture until it has soemthing it can focus on. The proof in this is that you can put the lens in man mode and shoot all the pictures you want, in or out of focus. You can also point the camerat soemthing it can focus on and once it reaches focus it will take the picture. I found this while talking with someone in my ofice while pointing at the wall and having the camera keep running up and down to focus, then stop and not take hte picture. She put her hand on the wall it bingo, the picture snapped, then removed it and no picture again.
    This brings me to my complaint about the future of phography. When life was simple and you could snap a picture no matter what the settings were, you took full responsibility for the quality of your work. Now, the basic DSLR camera will take great pictures for 90% of the time, and it will stop you from taking anything that it can't understand no matter what you want to do.
     
  14. I had exactly the same problem with my Canon D450, but solved the problem without having to take the camera in for servicing. Turned out the focus adjustment ring was stuck, so I removed the lens from the body, readjusted the focus ring by simply rotating it, reattached the lens to the body, and voila - it worked again, just like new.
    Hope this helps.
     

Share This Page