Camera doesn't recognize Speedlite

Discussion in 'Canon EOS' started by natureslight, Jun 20, 2016.

  1. In an effort not to waste your time and effort, let me say unfront I am far from expert. I'm a non-fiction (travel and nature) writer who uses her photography is support of the articles I write. As will become clear, there are large gaps in my knowledge of flash photography and non-natural light shooting.
    I shoot with a EOS 5D Mark II and my second camera is the original EOS 5D. My flash unit is the 430EX II. Until this weekend I never experienced an issue using this system. Saturday evening I went into the yard to shoot tree frogs and my flash unit refused to fire. I checked the batteries and they were fully charged. I then checked the unit using the test-fire button and it fired without trouble. I then reattached the unit to the hot shoe and tried a fire using the camera's controls. No fire. I then removed the unit and attempted to fire using a shoe cord and it still would not fire. I tried setting the flash using the controls on the unit itself and through the camera's setting. Nothing. I tried attaching the unit to my 5D and experienced the same problem. After fussing around for a bit it seems as if the camera is not recognizing that the unit is attached. When I attempt to access External Speedlite Controls under the camera menu, I receive a message saying This menu cannot be displayed. Incompatible flash or flash's power is turned off. Other than this issue, the camera is working normally and the flash unit seems to be functional. Any idea of what is going on and how to resolve it? Am I doing something incorrectly? I'll appreciate any insight or help - thanks
     
  2. I suspect only physical examination of the equipment can give you a firm diagnosis, but it seems to me that you have ruled some things out. It sounds like a lack of a good connection to me, and the fact that it happens on both bodies and a shoe cord indicates that whatever the problem is, it almost certainly lies with the flash itself. Have you checked the contacts on the bottom of the flash? They are spring-loaded and should be sticking out the same distance. And they should be clean.
    If the contacts are good, there could be a problem with the electronics inside the flash.
     
  3. This can happen if the hot shoe on the camera is loose. Is the flash anchored securely in the hot shoe without any free play or wobble?
     
  4. I agree with Dan. Since you have the same "no fire" issue with two different cameras and since the flash will fire if you use the test-fire button, it sounds like you might have a problem with the flash, itself, particularly the spring-loaded pins on the bottom of the unit. If you Google this issue, you will find others with pin problems. It sounds like it was such an issue that Canon offered (and might still offer) a replacement part to fix the situation. Make sure all the spring-loaded pins are extended the same distance. A stuck pin could be your problem.
     
  5. It could also be an internal wire break. I would suspect one of the comm wires. I've had it happen on an older 580ex.
    Regardless, from your description, if it's not something obvious like a stuck pin, you'll need to repair or replace the flash. While it should be a relatively easy fix (if you've used a soldering gun and a small phillips screwdriver before), if you don't feel comfortable doing that (or with the hefty capacitor in the flash - which can present a shock hazard), then toss it and buy a another flash. It certainly is not (likely) worth having it repaired, as you find a replacement for ~$100 or so.
     
  6. I apologize for not returning to say thank-you or to update what happened with my flash unit. Unfortunately, life went sideways almost as soon as I posted my question and I've just now returned. After some fussing around, I decided to follow the advice offered and scrapped the unit. I was able to upgrade for less than $150 and everything is good now. Thank-you to everyone who offered advice.
     

Share This Page