Bug Reports Part 1: the list (expanded version)

Discussion in 'Photo.net Site Help' started by Leslie Reid, Feb 16, 2017.

  1. Note: As it turns out, there's a 10,000-character limit on posts, and the list in the previous version bumped into that limit. I've copied the list here into the first three posts to allow room for future expansion, and I've added a 4th post as a blank space holder in case another category becomes important in the future. So look for "Really big problems" in this post, "Bugs" in the next, and "Omissions and design issues" in the third. I'll continue to monitor comments in the previous version, but it would be more convenient if you placed your bug reports here, instead.

    There have been a lot of reports in a variety of threads about things that don’t work right or important functions that appear to be missing from the new site. I think it would be useful to have a centralized list of the problems found. This might help ensure that the issues of concern to us are not lost among the other comments in all those other threads, and it also might make it easier for the development team to provide feedback on the status of the fixes that are being worked on for particular problems.

    On this thread, post brief descriptions of issues you have encountered. I will try to keep an updated master list in this opening post so that multiple posts for the same issues aren’t necessary. Please keep the posts limited to bug or omission reports. I’ll be removing posts that are off-topic, but you can post discussions or suggestions on Bug Reports Part 2: the discussion. If you have a post that goes missing from this thread, simply repost it to the companion thread.


    The list so far (issues we know are being worked on are in blue; those that have been solved are in green; modifications or recent additions are in magenta, need more info in red, and if it's in olive it's a feature, not a bug):

    REALLY BIG PROBLEMS

    Flickering refresh problem on ios devices (appears to be solvable by deleting cached redirects on device--see How-to thread)
    Visitors to the site who are not logged-in members see only thumbnails in Forum posts (like No Words)--looks bad for a photo site
    Screen names have been lost (partially solved by How-to #30; still a problem for anyone?)

    Comments entered onto the Critique page during the evening of 22Feb disappeared (comments lost but issue solved; won't reoccur)
    Unknown # of members cannot log onto site due to 403 error: forbidden request (now reported solved on 3/3/17!)
    Can't see photos in one's own non-public galleries (solved with Library view option)

    Important information in old database now not accessible:

    all old messages have disappeared (update: they are in database and will eventually be restored)
    equipment lists and serial numbers not available (update: they are in database and will be provided)

    overall gallery comments are gone
    equipment details (camera & lens type) that were entered with each photo uploaded to portfolio are gone

     
    Last edited: Mar 27, 2017
  2. color codes: being worked on, solved, recent addition, it's a feature not a bug, need more info

    BUGS
    Portfolio:
    EXIF data that are listed are not always correct - [the data we have is what was uploaded]
    the avatar upload button visible in Safari in My Portfolio does not work (solved--misplaced button removed)
    no place to add lens info
    clicking on favorites image inconsistently causes 404 error
    replacement home-page photo doesn't stick for some (may be browser-specific problem?)
    attempting to remove photo from gallery edit view (not Library) produces an error
    replacement portfolio banner photo doesn't stick

    EXIF data uploaded with new images are incorrect (exported from Lightroom)
    favoriting a photo leaves no record on the photo that it's been favorited
    only the first 25 photos show up in "photo" view for some members
    EXIF data cannot be edited using Safari (Library view)

    Category, gallery, and title don't consistently stick for portfolio uploads for some users
    At least one member gets "upload failed" on attempting to upload images to their portfolio (Safari)
    Forums:
    "write your reply" overprints one's attempts to write one's reply (update: may be browser-specific)
    intermittent 404 error when accessing POTW from Explore tab--possibly browser-related

    intermittent 404 error accessing POTD & Critique from Explore tab
    avatar changes when entering locations under the Learn tab (solved)
    can't enter paragraph breaks without HTML code

    clicking on your icon at the top of the Forum page kicks you out to the site's Home page
    setting up alerts for forums does not stick for some users; may work for new threads & not new messages
    intermediate pages missing on old threads
    forum search results inconsistent (e.g., nothing listed for "sigma 24-35mm")
    under some conditions users cannot upload photos to forums using Firefox
    Search:
    search results for member's photos aren't in galleries [in a photo search you will get photo results]
    no obvious way for visitor to search for member's public gallery
    search for "member's photos" includes photos with member's name only in comments​
    General:
    page auto-refreshes and becomes unusable for many users (solvable browser issue--see how-to thread)
    link to renew membership doesn't work
    some photonet links are reported broken in Google searches - [301 redirects are in place, please send examples to contact@photo.net]

    "guests" (below Members Online on Forum page) doesn't register un-logged-in visitors
    can't message someone without knowing screen name, and can't find screen name from home-page profile
    Critique and comments on photos:
    cc's sent in comment notifications (solved)
    title and intro comment are concatenated in first comment under critiqued photo (solved)

    photos submitted for critique need to be listed in order of submission date, not upload date
    we're not getting email notifications for comments on our own photos
    Profile information:
    a year in membership length is lost for 9 to 10-yr members
    cannot edit some account information
    everyone appears to have become a resident of the USA

    lifetime members are being told they need to become members (solved: dealt with case by case)
    some users cannot access their account page
    cannot update email address
    avatar selection in My Account appears to work in Chrome and not Safari
    right-clicking upper right icon to open profile in new tab produces a new tab with someone else's profile page
    under "personal details," autofill for new user's home page gives only #, not the required URL

    a 3-month member is listed as a 2-yr member--solving the 10-yr problem created a 1-yr problem
    Reported problems that could not be reproduced; if you experience them, please report more details:
    sort by views may repeat the same images for some users? [I couldn't reproduce the problem]
    serif font keeps appearing for no apparent reason for some viewers? [I couldn't reproduce the problem]
    screen name suddenly became unusable for one member on 24 Feb - likely duplicate
     
    Last edited: Mar 21, 2017
    YAYUSA likes this.
  3. color codes: being worked on, solved, recent addition, it's a feature not a bug

    OMISSIONS or DESIGN ISSUES
    Portfolio:
    1/5 of photo height obscured by unnecessary info that should appear only with mouse-over (solved)
    Need to be able to navigate to top of gallery, not use arrow button (solved)
    When viewing photo, back arrow jumps you to top of portfolio, not to previous view; navigation difficult in portfolio (solved)
    Blue background distorts colors in photos; needs to be neutral surround (suggestion to make color a choice)

    Gallery order apparently cannot be specified; most recently updated gallery appears at top
    Not all galleries are shown for some members
    Changing order of photos in a gallery simply switches locations of two photos, making ordering very hard
    Changing order of galleries simply switches locations of two galleries, making ordering very hard
    Gallery order sort would be a lot easier with just a list of gallery names (not images) to reduce scrolling

    Titles truncated on gallery and portfolio views
    Portfolio thumbnail view is slices of photos
    --much better would be a smaller thumbnail of entire photo
    Need to be able to easily navigate to gallery in which a photo resides
    Need something more descriptive than "home page" to get from a member's profile page to their gallery​
    Forums:
    New posts you click on don't stay there on next view so you must hunt for them (click on Recent Posts to see all)
    Too much wasted space on avatars, requiring unnecessary scrolling (solved - I think icons are smaller now?)
    Mid-grey on light grey is hard to read (I think this is solved now?)

    No choice of which forums to view
    No "like" or "reply" option on the POTW​
    Critique
    Need on-site list of our own comments (solved--Portfolio page "Activities")
    Need on-site notification and list of follow-up comments (solved--Portfolio page "Activities")
    No editing available for comments made on photos after they are submitted (solved)
    Comments under "your activity" need to be in chronological order (solved)

    Email comment notifications need to distinguish between follow-up comments and comments on own photo
    Cannot attach an image within a comment under a photo
    "Activities" lists need redesign--1 month's critiques created 378 pages to scroll through to find a post
    Need to be able to turn off email notifications for follow-up comments on others' photos
    General issues
    Can’t stay signed in for more than one day (no "stay signed in" option)
    Site home page images are too big; can't tell there's content below (solved)
    Need classified ad section (solved: see new Classified forum under Equipment)

    Pinterest buttons need to be opt-in due to concern over frequency of copyright infringement on pinterest
    Too much scrolling required
    Need just a list of favorite photographers, not icons - [adding list view]
    Need an option to just list the comments made (instead of thumbnails), since some members have 1000's
    Need to have a site announcement forum for staff to post info of use to all, such as outage notifications
    Need to have some indication on forum page that a spam message has been reported

    Each page or view needs a unique and intuitively clear name to make navigation easier
     
    Last edited: Mar 16, 2017
    Jack McRitchie and YAYUSA like this.
  4. -- a space-holding post just in case future expansion is needed --​
     
    Last edited: Feb 16, 2017
  5. brf

    brf

    don't know where to add this, but here it is : Let's say you want to post a comment on a photo, whether one's own or someone else's, no matter, along with that comment you want to upload a photo to illustrate a point or to show an adjustment made to the original photo. It used to be when adding a comment (or critique) there would be a request if you want to upload a file-no longer there. That is the question- how can this be done now? Thanks Greg Sava

    also: in the past (way back then) the exif info would be uploaded with a photo when posted for critique. There still seems to be a few things automatically there, but they are really weird and not correct. For example- here the model is correct and the iso, however the real shutter was 1/80 and the aperture was f-14. I see no way of correcting or changing these. Any ideas? Greg SETTINGS Model ILCE-7RM2 Shutter Speed Value 6321928/1000000 (6.322) Aperture Value 7.6 Iso Speed Ratings 250
     
  6. xxxxxxxxxxxxxxxxx My portfolio is a mess. Not arranged to date uploaded. Also my Screen name is Alex S., not Alex_Es. Furthermore, why is Photo.net using a photograph of me that I removed without my permission? I will consider whether to allow Photo.net to use that photograph after the person in charge asked my permission.
     
  7. Uploading avatar photos: On Safari, I see a "choose photo to upload" box under the default silhouette avatar in My Portfolio, and the same thing in Account, but there there is also blue text next to the silhouette in Account giving the option to upload an avatar photo. I was not successful in adding an avatar photo from either of these locations. I switched to Chrome, and there was no option to "choose photo to upload" in "My account" and no indication at all that it was possible to upload in "My portfolio." Going into Account and clicking "Upload a new avatar" worked with no problem in Chrome (on a second try my browser asked to OK use of Adobe Flash). Interestingly, when I first entered the Account page I noticed a "choose photo to upload" box appear for an instant and then disappear.
     
  8. My avatar icon changes when I click on an option under the Learn tab. The account and profile info are correct, but I've suddenly become a cherry blossom.
     
  9. When I go to Galleries on my portfolio, I can choose a particular gallery to view. If I click on a thumbnail within that gallery, I get an expanded view. However when I click the back arrow to return to that gallery, I am taken to the top of my portfolio (Photos) page instead. Anyone else experienced this problem? Lots of odd navigation programming in this version. And while I'm at it, I can still only access thumbnails in the recently added Library. 90% of my portfolio is still available only in thumbnail size.
     
    Last edited: Feb 17, 2017
    sjmurray and YAYUSA like this.
  10. Hi, Jack - I'd just tried that about a half hour ago and found it was returning me to the previous view, so now working as I expected it to. I'll try it again with a different browser--which browser are you using?
     
  11. The modification to square thumbnails in the Portfolio view is a great improvement--thanks! The ideal would still be to have small thumbnails that show the whole frame. The reason for this is that when we're in the portfolio view, we're using it as a workplace--we're usually choosing among and organizing a large number of photos. That means that the more photos we can see on the screen without scrolling, the better (up to a point, of course). For the same reason, being able to see the actual format means that we can work with the thumbnails themselves, rather than having to open each photo, which takes up to 15 seconds at the moment (I know that'll improve, and I also have a slow computer). But there've been some really nice portfolio modifications today--very much appreciated!
     
    Last edited: Feb 17, 2017
    Wayne Melia likes this.
  12. Thanks, Leslie, I'm using Chrome.Which I've been using as my primary browser with no problems on other sites. I'll go give it another try as this new version seems to have a mind of its own and apparently changes the way it operates on the whim of the moment. By the way, the ability to edit comments on pictures seems to have been completely eliminated. Check that also, will you?
     
  13. Leslie - I just went back and tested it again. The problem remains; I'm still being taken back to the top of my portfolio. As I said, I have a desktop computer and I'm using Chrome.
     
    sjmurray likes this.
  14. Turns out that the modification wasn't--the slice width depends on the width of the window open on the screen.
    <br><br>
    I also retested the back-button behavior, and found the same problem with Safari as Jack did with Chrome.
     
  15. Thanks for all your efforts Leslie! Making a proprietary platform such as Xenfor or vB behave properly in a multifaceted community is a herculean task--and some things may never sort out to full satisfaction or intended behaviors.
    .
    .
    Keep up the good work, and think about the rewards! There must be some reward--right??? :confused:
     
    Leslie Reid and Julie H like this.
  16. Leslie- Can I add disappearing cover photo to the list of issues still. I have set the same image multiple times but everytime I return it is gone and has to be reset to make it visible (that is if it's really linked still?)
     
  17. Hi, Phil - Something I've been noticing is that some changes stick in Chrome but not in Safari (I use v. 10.0.3). Which browser were you using?
     
  18. I've copied Phil Light's recent comment on the original Bug Report thread here in order to keep new reports in one place (though I'm still monitoring the old thread):
    <br><br>
    1. Still first priority is to get a full view of all galleries again for the Gallery View. Still only showing four them which means images can only be edited if they are reachable through the general photo scroll. 2. Also wondering if it might be possible to get our equipment lists back? I used that list to enter and track serial numbers in case of theft, fire or accident. It would be a monumental task to re-assemble that list from scratch again. 3. Still cannot view images in a hidden gallery (Archived). I have found two images through total photo scroll but this is definitely the long way around.
     
  19. I've copied Paul Stenquist's recent comment on the How-to Manual Part 1 thread here in order to keep new reports in one place:<br><br>

    Verbatim from Paul: "Much of what is said here doesn't work. The site has only gotten worse over the past few days. I'm trying to provide a link to one of my galleries. I go to "Galleries," find the gallery I wish to show, and I click on "view gallery." I get this really clunky workspace type display rather than a nice gallery. I copy the URL at the top of the page and send it to someone. When they use it, they get a pitch to join photo.net. Another person I sent it to, who is a photo.net member, get's his own page!! WTF, people. Why did you offer this site when it was barely a work in progress. Its broken. Seriously broken. Go back to the old site. You aren't capable of implementing this."
     
    Greg Pichnej likes this.
  20. Norman

    Norman Norman T Naffington

    Pnet's incredibly annoying implementation of flicker is back on ios devices running safari.

    This is costing me WONGA as I am on PAYG and the superfluous page loads are eating into my monthly data allowance.

    Please fix.
     

Share This Page