Bronitca ETRS shutter won't fire.

Discussion in 'Medium Format' started by ryan_campbell|2, May 5, 2010.

  1. I recently came across this forum when searching for a solution to my problem.
    I have only had this camera for a day now and while it is my first medium format camera I have had some experience working with other cameras of this format before.

    I shot a roll of film when I first got the camera and developed it with no problems but it was when I went to put in a new film later on that the problem developed.

    As far as I was aware at the time I loaded the film very carefully into the back, attached it again and wound the film winding crank until the s wound round to 1. At this point it was ready to take an image and when I removed the dark slide I depressed the shutter release button fully and nothing happened. The winding mechanism wouldn’t move any further as if it was fully cocked and ready to fire however the shutter or mirror would not trigger.

    I then looked online for a solution and have downloaded and read the manual. I have removed the film and put in an old film back to run through the process again this time following the step by step guide in the manual. As far as I can tell the film was loaded properly first time, but definitely the second.

    I have tried the dark slide in and out and the multi exposure meter in both positions. I think I have isolated the problem to the body as I have stripped everything off the body itself and the problem is the same whereas when I first got the camera and stripped it down and I was able to fire off and cock the mirror in the usual way. This was before I shot off my first roll of film so I know that I didn’t mess anything up at this stage.

    -The battery indicator is showing the battery to be normal,
    -The mirror is down,
    -When the back is removed the winding mechanism on the body just turns and clicks once a revolution, when set to multi -exposure it rotates once, clicks and stops as if cocked and ready,
    -Shutter speed is set to 1/500 s to have it working mechanically although I have tried on various other shutter speeds,
    -Has been tried with lens attached and removed,
    -Shutter release button is set to the fully unlocked position and fully depresses as under normal working conditions however nothing else happens at this stage.

    I’m sorry for the long post however I am just trying to provide as much information as possible. Any suggestions would be greatly appreciated.

    Many thanks in advance, Ryan Campbell
  2. I remember the ETRS much less well than other MF cameras but if you're sure you've missed nothing the first thing you could try is a fresh battery - despite the indicator showing good. Also try it with a cable release.
    If that makes no difference the likely cause of the problem is that the contact faces of the release electromagnet and its lever need to be cleaned. Very common fault with electronically controlled shutters too.
  3. One more thing you can try: a cable release in the socket on the side. Also, as suggested, try a new battery, preferably not lithium.
  4. Battery will not be the issue, remember that the camera defaults into a 1/500 shuttertime if the battery is dead, so if the battery is dead it should still work. Trying a cable release on the other hand might be a good idea to see if the problem is the shutter button.
  5. Right you are about the battery, Uncle Goose. The mechanism, except for shutter speeds and metering, is mechanical.
  6. Apologies for the misinformation in my previous response. Thought I remembered the ETRS had electronic release - wish I could remember not to trust my memory...
  7. Make sure that the lens contacts are clean, the lens shutter is fully cocked before mounting the lens, and try winding/tripping the release with the control lever on the body in different positions. You might have just pushed the lever to the wrong position, or a signal pin from the film back may be stuck. Fiddling with the control lever on the body should identify a signal pin issue.
    My camera is the ETRSi version, and I'm not really clear about the differences between it and the earlier versions, so I can't suggest specific things to try. Still, they are all reliable cameras, and it is more likely that you missed some operational key than it is that the camera just died between film rolls... It's the nature of the beast. Until you really become familiar with the interaction of the the various settings, Bronica cameras can play dead very well until you get it right!
    Just for grins, check out YouTube for film loading video clips. It is possible that you were lucky the first time you loaded a roll, and got it wrong on the next couple of tries. Whatever you do, be patient. They really are solid cameras, so solve the issue one step at a time.

Share This Page