Bronica SQ-A shutter problem??

Discussion in 'Medium Format' started by martin_alston, Mar 20, 2006.

  1. I just got in a used Bronica SQ-A. I was testing it out and reading
    over the manual while going over the buttons and switches. Everything
    seemed to be working fine. Then all of the sudden I can't trip the
    shutter. The mirror lock-up switch was stuck in "N" but the mirror
    was locked up. I could press the shutter button and there was
    pressure on it but it wouldn't release. I finally got the mirror lock
    switch to move but still couldn't fire the shutter.I tried loading
    the back with film and that didn't help either. Anyone go any ideas?
  2. The sqa shutter wont fire if

    1. the trigger is locked. unlock it.
    2. the back has a dark slide inserted.
    3. you fired once and did not crank
    4. ur camera is broken
  3. Well, the trigger isn't locked, the dark slide is out, and the crank has been turned and won't turn any farther. In the manual there are a few scenarios given that will cause the shutter not to trip and I believe I am free of them all. Just weird how it just froze like that.
  4. battery?
  5. Without the battery the SQ-A still works, although at a fixed 1/500 shutter speed. Of course it doesn't hurt to check whether it's still fresh by pressing the battery check button, but it isn't the problem.

    The mirror lock up button is a tricky one. When you turn it from N to S or C, then it is imperative that you do that in a quick decisive way. If you let it slip somewhat back to N, the mechanism can release the shutter without you realising it.

    So I'd check whether the lens shutter is cocked. This can be done by trying to remove the lens. Use the slider near the shutter dial. Move it downward, if the shutter is cocked, the lens should come loose. If it doesn't the lens shutter isn't cocked.

    I'd then check whether the back is still securely fitted and whether the insert is securely fitted in the back. Did you properly load the film? Does the frame counter show a number from 1 to 12? If not, then either you've not advanced the film enough, or you're already at the end of the roll.

    If that doesn't help, set the multiple exposure lever in the forward position. It may be necessary to crank the advance again. Then try to fire the shutter. This should always work.
  6. May sound silly, but do you have film in? My SQA won't fire the shutter unless the back is at 1 or later on the film counter. It will only dry-fire if you have multiple exposures turned on.

    Kinda freaked me out at first when I was just learning the controls.
  7. Yes, the film counter is on 1. I can no longer andvance the crank. I tried everything with the switch in multiple exposure position. Also, I cannot remove the lense since the shutter is cocked. Anyways, I sent it back to be looked at. Hopefully I will get it back in working order soon. I'm ready to shoot with it.
  8. I had a very similar problem with my SQ-Ai the other was only the batteries. And the AE Prism light meter still worked as did the battery check light, but the shutter needed more battery power. I only replaced 2 of the 4 batteries cause that was all I had on hand and then the shutter worked just fine. Good luck.

Share This Page