Bronica ETRS - Shutter Problem

Discussion in 'Medium Format' started by daniele_martini|2, Mar 22, 2008.

  1. Hi, I've just bought a second hand bronica etrs from eBay, and unfortunately I'm facing a quite annoying issue. The winding system and the shutter button seem to work fine, although the mechanism that is supposed to propagate the pressure of the shutter button to the lens seems to be not strong enough. More specifically, there are two levers on the front of the body which should put enough pressure on the correspondant levers on the lens in order to trigger the shutter, apparently there is not enough pressure to make this happen. Opening the back of the body, I was able to press (slightly) the same mechanism that triggers the shutter, and making it work in this way. It doesn't sounds as a severe problem, as the issue seems to be affecting only the "propagation system", while the shutter itself seems to work properly once it has been triggered. Any idea about how to sort this out? Thnaks in advance! Daniele
     
  2. One button on the front of the camera is for relaeasing the lens off it's mount. The other button is the shutter button. You don't need much preasure to fire the camera since it's electronically fired, you are mearly closing a switch. As long as the firing button returns after shooting, it's OK. If I were you, put in a new battery since you bought it used and who knows how long that battery has been in there, regardless of what the seller says. Save the old battery as an emergency standby if you think it's in decent condition. have fun with your new camera. I love these ETRS 645s.
     
  3. Thanks Paul! I forgot to mention that the battery check works fine. However the levers I was referring to are the ones placed between the camera and the lens. I will try to replace the battery, but for some reason I suspect that the problem might rely in a loose mechanism that needs to be calibrated. I've seen some other posts with the same problem, but with no solution :(
     
  4. Update... I've just tried to take some shots without battery at all and the performances are just the same (shutter failing most of the times), this makes me think that the shutting mechanism is entirely mechanical. If I'm not worng the battery is only used to support the exposure features of the AEII finder (which I don't have).
     
  5. The shutters in the Bronica lenses for the ETR series are leaf types. They all have a default shutter speed of 1/500. The battery powers electromagnets which slow the shitter down when any speed from 1 second to 1/250 is used. I think te battery is beeded for B as well but that the shutter can be manually locked open without draining the battery too. The lens must be cocked before being mounted on the camera, the dark slide must be pulled out and the single/multiple exposure lever must be in the right position. I have two ETRS bodies and an ETR. The two finders have are a plain prism and the waist level. If I do not put a working battey into the ETRS the shutter will fire but I will get 1/500 regardless of the speed set on the camera body.
     
  6. Thanks Jeff, My comment about the battery not involved in the "shutter workflow" was obviously incorrect. I believe that the issue I'm facing migh rely in three possible reasons: - the shutter spring in the body is not tight enough and therefore not enough powerful to trigger the shutter. - the lens shutter mechanism needs to be oiled, as now it is restistent to the pressure of the shutter mechanism. - a combination of the two. I've tried to simulate the shutter movement directly on lens, by keeping pressed the silver lever on the side and moving manually the pins, repeating the operation many times in order to smoothen the whole mechanism. This seems to improve the performance of the shutter, bringing failures to 1 out of 10 (from more than a half). As I have no idea on how to thighten (or replace) the body spring, do you have any esperience in oiling lenses? Any advice would be welcome. Daniele p.s. For further reference, this is a detailed description of the Seiko shutter used in Zenzanon lenses: http://www.buonaluce.com/Anatomy.pdf
     
  7. Both Tamron and KOH's will service this camera. I also bought some parts for an SQ series Speed Grip from Tamron. They were very helpful.
     
  8. Hi Daniele, I used Bronicas a long time, they're very good cameras and take a beating well. This is typical of when the lens spring gets lazy and the mechanism a bit dirty. It's really best to have it serviced by a shop that knows what to do. Then it will be reliable and run for a pretty long time. I had a SQ 150 that used to do this and I would takie it apart and clean it up and lube it etc. Then it would work for short time and fail again. Finally I just sent it to Bronica when they still exsisted and it lasted about 5 more years.
     
  9. The shutter release button also has a three-position ring that surrounds it. Rotate the ring and see if your shutter release works. All the way rotated locks the shutter. One click around frees the shutter button, and the next click allows you to use the speed grip to release the shutter. You don't need a battery to fire the shutter, as has already been mentioned by Jeff. If the battery dies the shutter goes to 1/500. Easy test: put the camera into Multiple Exposure mode. Take the lens and film back off the camera. *X&$#**X&$#**X&$#**X&$#* the shutter. Release it while looking through the body. The mirror will release and you can see through the body. If that doesn't happen then your shutter release is not working. (Check the knurled ring around the shutter release button to ensure proper positioning.) If the mirror does release, then the shutter in your lens may be acting up. No problem there. Bronica lenses are dirt cheap. It's cheaper to replace them than get them serviced.
     
  10. BTW, you don't have the dark slide in, do you?
     
  11. Thank you all guys! I will get the camera serviced or return it to the seller (depending on how complicated it is). Cheers Daniele p.s. John, yes I did remove the dark slide :p
     
  12. Hi Daniele, Did you test the body with another lens? Usually the problem is related to the lens, but sometime it is associated to the camera. If the cause is the camera it only needs a CLA (clean, lube and adjust) performed by a service center, definitely it will cost more than a new eBay body but at the end it will result in a well operating equipment instead to bet on getting another exhausted body. If the problem is the lens, definitely it is correlated to the Seiko shutter and the spare part is very expansive so it is better to looking for a new lens. Max
     
  13. Daniele, I was sure that you had! I myself have done such silly things, and often a post like this one will be read by countless others doing searches for similar problems. I thought it might be good for posterity to include the simple things in a post that most assuredly will be searched by someone suffering a similar problem.
     
  14. Massimo, Thanks for the advice. Although I found a shop (Camera Clinic in London) which offer and estimate for 10?, which seems reasonable. John, I did appreciated the advice about the dark slide! It took me about 10 minutes to get why the camera didn't shoot the first time i tried it :p Thanks you all again, I really appreciate the help you provide to people! Cheers
     

Share This Page