Bronica ETRS p[roblem

Discussion in 'Medium Format' started by paulcooklin|1, Nov 29, 2008.

  1. Hi - I cleverly dropped my ETRS a while ago on gravel which irritated me no end. I have recently shot a roll of
    film and developed it last night. Only 7 out of the 15 shots came out, the other 8 were completely blank. I
    thought at the time that it sounded like the mirror didnt seem to flip as I didnt hear the normal "clunk".

    This morning I shot another roll of film with another lens and this time all 15 shots are blank which makes me
    believe its the body for sure.

    Any suggestions? Is there anything I can do to try and fix it myself or what should I be looking for.
    Many thanks.
    Paul.
     
  2. paul ron

    paul ron NYC

    Shutter is in the lens. Take the lens off n try firing the body n lens separately. Also the prism depending on which one you have may not be making it's electrical contact n cause a problem. Bad battery is another factor. Try to isolate the problem first.
     
  3. Yes I know the shutter is in the lens, but doesnt the mirror need to flip up in time as well?Also, it seems
    unlikely that both lenses were faulty if it was the shutter. I will try your suggestions first though and report
    back.
    Thank you, Paul.
     
  4. Paul - I shot another film but this time used a WFL no extension tubes or sppedgrip, just the basics and again nothing, completely clear negs.
    I wasn't able to trigger the shutter without the lens being mounted, how do you do that?
    The lens seemed to open and shut and I heard the mirror flip with its normal clunk sound. It seems to work fine from the sound and appearance. I also thought perhaps my developer was dead but that seems unlikely as some of the frames were exposed ok last night. However, 2 rolls today have nothing, not a single frame. I know nothing about the mechanics of the camera, but my guess is that the mirror isn't flipping up/down at the correct speed, what do you think?

    Many thanks, Paul.
     
  5. paul ron

    paul ron NYC

    Dark slide in... Take the back off the camera n look through it as you fire the shutter. Try it at all speeds n see if it is working? If not like I said, isolate the problem to one companent. Your prism isn't the problem.... now work out if it's the back or body or lens. BTW don't waste your film... dry fire it instead. Use the multi exp to fire without film.

    At 3 O'Clock of the red dot on the top of the lens there is a little thing that sticks out of the edge... push it in n fire the shutter by turning the pins away form the green dot. Turn the pins to the green dot n do it again. Be sure to cock the shutter before mounting the lens on the cocked body.
     
  6. Paul - Thanks but Im unable to dry fire it (no lens or back etc) in multi mode. The crank turns and turns but wont fire..the button is soft but nothing happens..it did fire the first time I did what you said but it's not now since not being able to mount to lens problem...can you help?
    Many thanks.
     
  7. paul ron

    paul ron NYC

    Put the multi exposure lever down into multi exposure mode.
     
  8. I have switched it between multi (lever up) and normal, lever horizontal, still the same. When I mount the lens, it goes on and stays on but I can twist and take it off without releasing it. Its like it’s not locking the lens or something. Ive cocked the lens first. When Im just trying to fire the shutter without a lens, back or lens, it still doesn’t fire now in multi, but it did before...any ideas? Its probably something obvious but I cant work it out. Or, the body has broken somehow which is odd because before all this, it did fire etc, but I didn’t realise it was in multi-exp mode.

    Many thanks for your time Paul.
     
  9. Hi:
    Try removing everything from the body(lens,speed grip,finder,back). Check your battery voltage with a volt meter before continuing(the red battery light may light but still not have enough juice to operate the camera)

    Then put the multi switch on the side to the forward position(this engages the multi function). Then turn the crank until the body is cocked. Look thru the body as you fire the shutter. This will tell you whether the mirror is operating properly.

    If this looks ok then use a pencil eraser & clean the contacts on both the body & lens. Attach the lens & try the same thing. Try all the speeds.

    It sounds like it will be in the body or lens as the back advances the film ok.
     
  10. Jimmy - Ive just replaced the battery. Ive stripped the camera down to just the body and put it on multi exposure and normal but it wont fire at all...the button goes in, but nothing happens. This is now a new problem since my posts above, after I took it apart and followed the other Pauls suggestions.
    The initial problem was clear negatives with only 7/15, the second roll today produced 0/15.
    Im now not sure what to do. The camera doesnt fire at all at any setting and Im not sure the lens in on properly which may indicate something to you. It goes on, but doesnt seem to lock properly, i.e I can just twist it off again without engaging the release. Is the release jammed perhaps, would this stop it from firing?
    It did fire a few times when I took it apart initialy, then stopped when I tried to mount the lens.

    Many thanks.
    Paul.
     
  11. david_henderson

    david_henderson www.photography001.com

    If the lens is not properly locked onto the body it will not fire.

    If you cannot lock the lens onto the body after dropping it, then it is likely to need help that few users can give it.
     
  12. Thanks David - this seems to now be a new problem which have been caused by something I have recently done while trying to figure out the problem (as above). I have a feeling you could be right in that it's beyond any helpful information, but Im wondering if there's a way to get the lens to lock again as this wasn't a problem before today. Paul RON has very kindly offered his help and I think he's looking for an answer, assuming it's not faulty and only a user problem.
     
  13. You might want to consider just replacing the body rather than try to get it repaired. ETRS bodies are pretty cheap, there is an ETRSi on the "auction site" for BIN $89.95, for example. Good cameras, but no resale.
     

Share This Page