AV-1 Light meter problem

Discussion in 'Canon FD' started by 10957614, Nov 19, 2017.

  1. Hello, I am hoping to get some feedback on my AV-1 problem. The light meter jumps to the top of the scale when it is pressed half way. I have switched the batteries out, and as I write this I am wondering if the other battery was in good shape....... anyways when you first pick up the camera the light meter seems to function, but the longer you hold the shutter release half way the higher it climbs. From then on it just jumps to the top of the scale. Until the camera sits a bit (the battery gets back a surface charge?) Then it meters ok until I you hold the shutter down again. I am going to check the battery again, but if anyone else has an idea that would be great.... tom

    I just checked the battery it is at 6.62 volts and I changed it with another that was the same voltage and the needle still pegs out at the top.
     
    Last edited: Nov 19, 2017
  2. Still no reply?

    My A-series meters work just fine, and when I have seen symptoms on other cameras of battery-failure-in-progress, it has been symptoms such as you describe.

    Do you have a manual (link)? There are lots of details about how to use the meter in stop-down mode and other ways that mean all the little settings need to be right.
     
  3. I tried replacing the battery with a new one, and I still get the same result. Because the AV-1 is aperture priority the shutter fires at 1/1000 now all the time unless it is set to flash sync mode (1/60). I had been using the camera for about 8 months before this started.
     

Share This Page