A few graphical/design changes around photo.net...

Discussion in 'Photo.net Site Help' started by joshroot, Jul 8, 2008.

  1. Bug/fix update thread now at:

    http://www.photo.net/site-feedback-forum/00Q6mS
    Some changes...
    If you haven't noticed already, you will notice in the next few minutes that we've switched up the way a few of the PN pages look. Some of the changes probably won't be noticed by most people, some will be seen every single day. While there is something comforting about a site that looks the same as it did five years ago, the fact is that ignoring design can hinder updating a site with features that are commonplace elsewhere. PN fell behind in various ways as far as site design and features, we're working hard to fix that.
    • Individual forum pages redesigned.
    • "Gallery" main page redesigned.
    • Portfolio/Folder and Top Rated Photos pages redesigned.
    • Individual photo pages slightly redesigned.
    • New User Registration page.
    • Individual forum pages
      This is the change that a majority of users are going to notice. The individual forum pages have been changed to add a little more space between thread titles, use a slightly different and stronger font for the titles, add in the number of replies for each thread, and add in a "most active threads" section at the top. Having the number of replies listed for each thread is something that users have been asking about for a couple years now and it is very overdue. The "active threads" list defaults at 4 threads but can be expanded to 8 and is based on the top 8 threads with most responses in the last 7 days, ordered by descending number of responses in last 7 days. Make sense? Just think of it as the threads where you are most likely to find a heated discussion about Canon vs Nikon.
      Please Note: The Unified Forum View currently has the old forum style. That is because of the unique customization that the Unified View offers users. We will be switching it to the new design in the near future, we just want to make sure nothing goes wonky when we do.
      Gallery Main Page
      The gallery main page (the one you got to when you clicked straight on the "gallery" tab) has always been pretty useless. The most redeeming feature was that it showed the most recent photo submitted for critique. The new page uses more thumbnails for the different links and gives viewers a lot more incentive to click through and look at your images.
      Portfolio/Folder and Top Rated Photos
      The portfolio view has been changed to include a quick way to toggle the details off and on so viewers can see ratings, number of comments and number of views for each image. The grey background has been made lighter to help the images stand out more. And the hard-to-see button for viewing as a slideshow has been changed to be more obvious. The Top Rated Photos view adds in a few of those same changes. But also removes the sidebar advertisement and increases the number of images to 16 (4 across and 4 down).
      Individual Photo Pages
      The tabs at the bottom have been changed from tiny hard-to-read boxes into proper tabs. A "critique image" link has been more prominently placed. And the Digg/Reddit/Delicious link box has been moved away from the top of the image and down where it isn't so badly laid out.
      Please Note: Yes, the "larger" link is gone. However, you just click on the image itself to see it in the "larger" version. Less clutter on the page, easier for users. However, I suspect that we will have to add in a "click to see a larger version" note until people get used to it.
      New User Registration Page
      To be honest, none of you who are reading this will probably deal with the new user page, but it has been redesigned to be less confusing and to spell out the differences between what you get with a subscription and without.
      What to do if you are angry beyond belief that something has changed
      Well first off, cut back on the coffee and calm down a little. These are graphic and feature additions that are meant to increase participation on photo.net. That means more people answering your forum questions and more people looking at your photos. Yes, it looks a little strange to me too, you really get used to a page looking the way it did yesterday (and the day before, and the day before). But I've used this version of the site for a week or so now and it has really grown on me. Particularly the new forum view. I can see which threads have a lot of replies and which might need my expert advice. And after you get used to it, the new font and spacing makes the thread titles a lot easier to scan.
      But if you have questions or concerns, please drop me a line via the "contact photo.net" link at the bottom of the page.
      EDIT: Sorry, forgot the individual photo page section. trying to do too many things at once I guess.
      ** READ ME **
      These are the current known issues/bugs:
      • Some users browsers not using most current javascript files. Should be fixed as of 7/9 AM
      • "details" tab not working for some people
      • visited links are not changing color. Fixed as of 7/9 AM.
      • "Rate" tab appearing on images that has not been sent to critique forum. Fixed as of 7/9 AM
      • "Rate" tab is not working even for images that HAVE been submitted to critique forum.
      • "ecard" tab appearing on images in folders that have ecards disabled. Fixed as of 7/9 AM
      • http://www.photo.net/community/ page is graphically messy. Fixed. turns out that the most recent version was not loaded at launch.
      • The words "show details" missing from "+" on folder view pages. Fixed.
      • "show details" and "+" missing from folder view pages when owner is looking at their own folders. Fixed.
      • We're working on all of them. If you are coming to this thread to report one of these bugs, thank you, but there is not need. We are already aware of these. Please let us know if you are experiencing anything new.
     
  2. Just found this explanation - phew, I thought I was going crazy as it changed from one view to the next for me.

    By the way, I like what I've seen so far...
     
  3. WOW ! ....Very well done I love it ,...took me a little bit to figure out where all the buttons are ..but much better ...You all
    deserve a well done buy you a beer next time i am in town .
     
  4. I like the new look , bolder, easier to read, more graphically contemporary or some such thing. Clicking on the photo is a much bigger target than that "larger" button was.

    Maybe it's because I've stopped drinking coffee, but the new look has a calming effect on me. I can't come up with anything in the changes worth going off the rails about.
     
  5. Uuups - can't open the tabs "Details", "Send ecard", "Photo Admin" and "Rate Image" with my OPERA-browser any longer :-(
     
  6. Hmmm,

    I've got to say, I test in Windows IE, Windows Firefox, Mac Firefox, and Mac Safari, but I don't test in Opera because it really is the lowest use current release browser.

    I'll have someone look into it.
     
  7. Coming along nicely, Josh. Handsome changes. I like 'em.
     
  8. Dirk, what version of Opera are you using? I just downloaded the latest version and the tabs work fine for me.
     
  9. Dirk: upgrade to 9.5(1)
     
  10. I use the newest 9.51 - no reaction.
    No problem with IE and FF
     
  11. Everything works fine now - I had to activate Java, I think.
    Thanks a lot!
     
  12. I agree the new design offers a more calming, organized feel to the overall layout. Nice choice of font arrangement of elements. Great work, guys! umh...Any chance this little issue will ever get resolved?...
    00Q6CS-55249584.jpg
     
  13. I like the thread counts, etc., but two things I think are a step back:

    - Forum post titles no longer change colour as 'visited links' when clicked (at least in Firefox), so it's very hard to keep track of the threads you've read in busy forums.

    - The way Forum names & 'active threads' are interleaved on http://www.photo.net/community/ is deeply ugly and distracting. Move the active threads to a sidebar or something so it's less of a jumbled mess?
     
  14. Tim, you have the default font size increased, correct?
     
  15. The visited links thing must be a glitch. Are the IE users seeing the same issue?

    I agree that the http://www.photo.net/community/ page needs some help. It is very hard to read.
     
  16. Josh,

    The standard font size in Safari 3.1.1 Preferences is set to Verdana 16. I also did a (Command + & -) to increase the font size
    while the menu was pulled down and the lines of garbled/overlayed menu items began to separate to their own spaces but doing
    so caused the rest of the fonts on the page to become huge.

    Do I need to reduce the Standard Font Size in Safari's Preferences? If so, I'll give it a try to see if it fixes this.
     
  17. Opera 9.50 with Mac OS 10.4.11. Everything works fine and dandy.

    Camino 1.6.1, same os, works as well.
     
  18. Tim,

    Just take a look at it with font font set to "default". Meaning, let the website you are visiting decide what the font size should be and not your browser. That way we might figure out what the source of the problem is.
     
  19. The only way to get the menu items to be readable though with very little line spacing is to Command (-) all the way down to
    max. Once I empty the Safari's cache, quit Safari and restart Safari it goes back to what it was. The page fonts are affected
    separately using the command +/- at a threshold set by the font size selected in Preferences. I can keep Command (-) all the
    way down and the page font won't get any smaller.

    Only the line spacing for page fonts will be affected at a certain level before the font size increases when using Command (+).
    It feels like there's some subgraphic grid structure Safari uses that's not standard to other browsers and is controlled by the
    Standard Font size setting in Preferences.

    I don't know where default font size is selected in Safari and where it says to let the. All I have is the Standard Font and Fixed
    Width Font which is set to Monaco. Then Default Encoding is set to Western (ISO Latin 1). Universal Access is set to Never
    Use Fonts Smaller Than 14 points.
     
  20. Visited links ARE showing an alternate color in MSIE v7, from where I'm sitting. Likewise with FF v2 (haven't tried v3 yet).
     
  21. I do not like bold (or what looks like bold) fonts for *all* the threads titles. Kind of makes it harder to glance through I think. It would be nice to have the threads where *I* responded in bold (with the help of cookies), but not all of them.

    Thanks.

    - Sergey
     
  22. Sorry about this line...

    "I don't know where default font size is selected in Safari and where it says to let the."

    I meant to say I don't know where it says to let the website control fonts in Safari Preferences.
     
  23. Josh I have the same problem as Tim. I have the option picked to allow sites to choose fonts but the only way the menu isn't mucked up is if I set the font size for 10 and that is waaaaaaaaaay to small for me to use. Can't read type that small on my screen.
     
  24. Here's how it looks when Command (-) to max.
    00Q6Fb-55261584.jpg
     
  25. What about the e-cards option? I'd formerly had this feature disabled, but now it's enabled, and I didn't enable it. And when I click on the Photo Admin tab, the only option shown is "enable e-cards."

    I don't want this "send e-card" feature enabled on my portfolio. How do I disable it? I'm using IE7, by the way.
     
  26. Looks great, Josh! :)
     
  27. How do I opt out of the "send E-card" feature? Is this new?<br>
    I'd rather not have my pictures mailed all over the place as E-cards.
     
  28. Found fix by turning off Universal Access-Minimum Font Size.
    00Q6HC-55269684.jpg
     
  29. Mary, can you give Tim's solution a try? I had a feeling it was something like that. Good sleuthing Tim.
     
  30. Jim & Mike,

    Give me a second to look into the "ecard" thing. There is obviously a glitch in there somewhere.

    And why would anything ever go smoothly for me? Still, I'm pleased at the positive response.
     
  31. Universal Access seems to be the culprit in all this because I just turned it back on and reduced the font size from 14 to 12 and
    all is well. The fonts in the menu and pages are all perfectly sized for legibility.
     
  32. That is great Tim. One less thing on my "to do" list. A big "thanks" to you.
     
  33. I have IE 7 on two machines and the thread titles don't change color when I click on them. Also, I have to admit that
    the bold type is harder to read. The letters are thick without good definition. I'm sure I'll adapt though.
     
  34. Jim & Mike (and anyone else who wants to turn off ecards): Go to your gallery, click on one of the folders, then look for the "admin" link on the upper right corner (you need to be logged in to see it). Click on the "admin" and a box of options will pop up. One of these is "disable ecards". My apologies for any confusion or problems.
    00Q6II-55271584.jpg
     
  35. Your welcome, Josh. I'm glad I finally figured it out as well. What an ordeal!

    But really if it weren't for my lack of reading the freakin' manual on exactly what Safari's Font Prefs actually do to web pages
    this probably wouldn't have ever come up.

    Oh...wait a minute, I forgot, there is no freakin' manual. Hey Apple, you listening?

    Just FYI to other Safari users on Photo.net. I set my Standard Font to Verdana 17 which only affects the font STYLE not size
    used in the menu dropdowns. The 17 font size affects the font spacing and size of the entire page but not the font STYLE in regards to serif
    fonts. Universal Access font size affects the size in the menu's and the small san-serif text just below and within the banner graphics at the top
    of the page.

    You could try other font sizes but 17 for me was the max before the serif style text postings as read in this thread went way too
    big. You might afterwards want to empty Safari's cache, then quit Safari and relaunch and reload a Photo.net page to test to
    see if it sticks and/or affects other sites. Command (+/-) font size settings are dumped and returned to default after the cache
    is emptied.

    Clear as mud ain't it? I swear fonts and computers have never been on friendly terms and it looks like they never will.
     
  36. Regarding eCards (and ratings).

    It appears that the "rate" and "ecard" tabe are showing up on images even when they have ecards turned off or have not been sent to the critique forum (to enable ratings).

    This is a glitch, we will get it fixed.
     
  37. Josh, I'm also getting the visited links problem in IE7.

    In FF3 I can override this by disabling 'allow pages to choose their own colours' in the browser Options, but
    this wasn't necessary with the old site.

    That's a definite improvement to the community page, but IMHO it could still use more of a separator between the
    forum names section and the active threads section.
     
  38. for some reason i no longer have any tab for details ?
     
  39. I should perhaps be more clear. When I acknowledge that there is an issue, that doesn't mean that the issue has been fixed. It just means that it WILL be fixed.
    These are the current known issues/bugs:
    • visited links are not changing color.
    • "Rate" tab appearing on images that has not been sent to critique forum.
    • "Rate" tab is not working even for images that HAVE been submitted to critique forum.
    • "ecard" tab appearing on images in folders that have ecards disabled.
    • http://www.photo.net/community/ page is graphically messy. Fixed. turns out that the most recent version was not loaded at launch.
    • Visited links not changing color correctly.
    • The words "show details" missing from "+" on folder view pages. Fixed.
    • "show details" and "+" missing from folder view pages when owner is looking at their own folders. Fixed.
    • We're working on all of them.
     
  40. Might be OK .... if it worked .... I'm using IE7 with AOL on WinXP and NONE of the tabs work ! ..... any ideas ?
     
  41. i have the same issue that jeffrey has. had the details tab and then it disappeared. josh, these "bug" threads probably aren't as
    entertaining for you as they are for me. i love to watch you work. now carry on.
     
  42. I'm using IE7 with AOL on WinXP and NONE of the tabs work"
    Are you using IE7 on it's own? Or is it some sort of integrated AOL-IE7 thing?
     
  43. Jeffery & Mary. What browser are you using?

    Also, everyone should be aware that if the programmers are working on stuff, that could be causing weird results while they update and change.
     
  44. i'm usually on firefox 3. thought that might be the problem but same thing with safari 3.1.1
     
  45. I am using a gateway gt5412 on this line , with the new microsoft operating system ,,,,windows vista ...
     
  46. Josh, I was using AOL/IE7 "integrated thing" .... didnt think of trying IE on its own until you mentioned it. I then found that tabs worked OK with IE on its own AND (suprise, suprise) , when I went back to AOL, it worked there too ! .......... Thanks !
     
  47. oops wiindows explorer sorry ...
     
  48. "josh, these "bug" threads probably aren't as entertaining for you as they are for me."
    I'm going to have to agree with you on that, I bet it's much more entertaining for you. My opinion is more like Jack's below.
    00Q6NZ-55299584.jpg
     
  49. "The portfolio view has been changed to include a quick way to toggle the details off and on so viewers can see ratings, number of comments and number of views for each image"

    Where ? .. How ? ..... Having got the other tabs to work on AOL this appears to be my last remaining problem.

    I dont see any such "toggle"
     
  50. Okay--what's the secret to opening the "details" and other tabs?
     
  51. Still no properly working "new answer" page.
     
  52. I appreciate the effort, Josh, but the solution does not seem to be working. After disabling the E-Cards, the "Send E-Card" option is still there and appears to be functional.<br>
    Thanks though, I know you're working on it.
     
  53. Visited links are not changing color. Same problem you had previously when you changed servers?
     
  54. Find the font for image comment (critique) text to be quite tiny. Using IE7 on Vista Home Premium. Zoom set to 100%, page text size = normal. Monitor is 22" wide screen set to 1440x900 (capable of 1680x1050). I use this resolutiion for most tasks such as web browsing. Problem is not apparent on all pages; ie this page has a nice readable font.
     
  55. Ian,

    It's the plus sign to the right of the tabs. Sorry, I should have been more clear. Perhaps it needs the word "expand" or something near it.

    Bill,

    Are you asking about the same thing as Ian? Or are you talking about the tab that says "details"?

    Erick,

    What new answer page are you looking for? They all work for me. Which forum is it where they aren't working? The "new answers" page has not been changed, so there shouldn't be anything wrong with it.

    Mike,

    I listed the known issues at 5:50pm and that is one of them. It helps to read my posts before posting yourself.

    John,

    Same answer as Mike. Take a minute and see if this has been mentioned before. I the case of the links, it has been mentioned multiple times. Not to mention listed as a "known issue". We're working on it.
     
  56. Known issues/bugs list now added to original post as well.
     
  57. The "+" for expanding the details view in the folder page view and TRP pages now has the words "show details" added to it to make it's use more clear.
     
  58. works great on explorer but not with firefox (can not enter admin tabs) is this temporary. Is this a conspiracy that photo.net is in with microsoft?
     
  59. it's not fixed here, josh. i get admin options in the top right of folders and nothing else
     
  60. This thing is pretty buggy right now. I'll come back tomorrow...
     
  61. You should all be seeing this:
    <img src="http://static.photo.net/attachments/bboard/00Q/00Q6Qz-55321584.jpg">
    <p>
    If not, try a shift-refresh of the window. And/or logging in and back out again of PN.
     
  62. no, just admin options in safari and firefox 3. show details was there earlier today when the switch occurred and then disappeared
     
  63. Okay, I'm going to guess that the programmers are working on stuff, so I'm going to ask every to not freak out and give them a chance.
    Let me repeat that, please give the programmers a chance to do their magic. We can reassess where we are with the bugs later this evening.
    I'm going to go have some dinner now and feed the baby.
     
  64. Hi, I know that at the top you have stated that you fixed the details tab on the individual photo view, but I still can't use any
    of the tabs. Maybe it will take a while to work, but just thought I'd let you know. Thanks for all of your hard work. - Lex
     
  65. Josh--I'm talking about the tab that says "Details" and the "E-card" tab. I didn't try the other two. I use Firefox.
     
  66. Josh,

    Shouldn't the Leica & Rangefinder forum be listed under Photography Equipment forums.

    Thanks.
     
  67. "details" tab was there when I first say the redesigned "folder" page but now I don't see it. I generally like what I've seen. GJ oops, I didn't see Mary's earlier post. She is always one step ahead of me.
     
  68. Coolness, I like it how shows how many responses there to a thread.
     
  69. Font too small, so I make it bigger to read, then click on thread and font too big. Please make them consistant.
     
  70. Unless I'm mistaken, I don't think we're able to 'edit info' in regard to folder titles, etc. I just signed on, and I'm exploring the new format, but I couldn't figure out where that feature was and I need to change something in my folder title. As always, thanks for your hard work in trying to make this a better site for all.
     
  71. jsc

    jsc

    For everyone having difficulties with the new design, please try holding down shift while reloading the page you are having
    troubles with. An old version of the javascript files may account for many of your problems. You should only need to do this
    once.
     
  72. The "Details" tab is not appearing and I thought it was fixed. I use Firefox 3. It did appear earlier in the day. Can anyone explain clearly... please? I tried holding the shift key down with no success.
     
  73. From what I have seen I like it .
    keep up the good work.
     
  74. Thanks the shift trick seems to have worked. - Lex
     
  75. As Jin has shown, the programmers are working hard to correct glitches. So just keep cool and watch the magic.
     
  76. Safari 3 - details tab etc. not working.
     
  77. Erick, What new answer page are you looking for? They all work for me. Which forum is it where they aren't working? The "new answers" page has not been changed, so there shouldn't be anything wrong with it.
    It never worked properly. I didn't visit for a while and then I hit "New answer" and it says my last visit was today, and no new answers are found. It's been like that for years, since the beginning as far as I can tell.
     
  78. No folder details page on the 9th of July at 09:34 hrs (GMT+2). Ok, but I draw the conclusion that it is coming.<p>
    About browsers: I am using Firefox 2.0.0.15. If you would stick to standardized HTML none of the browser specific problems would occur. The net programmers tend to have the latest equipment which run the latest JAVA and Flash in a perfect way, but unfortunately the average user swears JAVA everyday. I've got the lastest Nortons and firewalls and no viruses no worms - and everytime I switch JAVA script on my mouse gets erratic - and I hear I am not alone. The only one that really works universally is standard HTML. As I understand XTML is Microsoft specific.<p>
    (Sorry Josh me being so jump on this views matter. I would say that the longer one is here the greater the weight of the view info. The ratings has lost its meaning to me as ... well for all the commonly known reasons. Comments, critiques are good but unfortunately too rare per photo. The views count is sort of objective number to measure the appeal of a photo.)
     
  79. Josh Root , Jul 08, 2008; 04:43 p.m. "Jim & Mike (and anyone else who wants to turn off ecards): Go to your gallery, click on one of the folders, then look for the "admin" link on the upper right corner (you need to be logged in to see it). Click on the "admin" and a box of options will pop up. One of these is "disable ecards"."
    Just to let you know, as of 0300 EST this morning, this isn't working. Plus, the "disable e-cards" choice only shows up in one of my folders...all the rest continue to have only the "enable e-cards" option available. Plus, even though I click on the "disable e-cards" option in the one folder it shows up in, the "send e-card" tab still remains on the photographs in that folder.
     
  80. How come you have to press reload in firefox 3 to vie details of the piczure or to rate it? That is bad bug:(. A lot of people don't know that...
     
  81. I know its late night there but I'm awake here and ready to mention a couple of observations.

    Something minor. About the bigger bold letters in the forums. Maybe they could be slightly less blue. Not to change the tone but the density of the color (more grayish).Just a bit.

    And something major (for me) in which I'm going to give you my personal view.

    In the portfolio view, the kind of warm gray tone seemed more inviting to me. I don't mean that the warmth of the background is wrong now, but I'm just giving you my impression in comparison.

    Still not my main concern...

    Considering the fact that I have a lot of folders that contain 3-4 images, all arranged in just one line within the folders, my main concern is, that I'm getting the impression of these images floating (not so pleasantly) into the folder background. The empty space under the images looks like (I repeat 'looks like') bigger than the one above them. Maybe (and probably) the length is the same but the gray box that contains the title of each folder creates this impression by making the above space to look sorter than the one under the images. The lighter background seems to increase this effect. I wouldn't be so sure (sometimes tiredness or other reasons may give a wrong impression) but there was a friend here last night (whose visual ability I value a lot), who confirmed that there is such an impression.

    I hope the only solution is not to rearrange the folders in order to have more images and therefor more lines of images to eliminate this effect.

    In any case, I hope I'm helping.
     
  82. I have the latest firefox ect ect and I can,t open any tabs,can,t rate, can,t even see my own ratings,Wrote a critique today on a photo and it did not show up.Something is wrong with this system.
     
  83. I have to second Birte's note. Shouldn't fixing the tabs be a priority?
     
  84. WooooooooooHooooooooooo ! .... at last the "+/- show details" tab has appeared on my folders and I'm a happy bunny now .

    I haven't found any other problems so far and it all looks pretty good to me - WELL DONE to all concerned
     
  85. i still have no details tab ,but i can rate and critique ...although damn letterings so small I cant evan see it ...oy vey ....good luck guys It does look better ,,,,once most of the bugs are driven out .....It will be ...however I see a crowd gathering over by the ratings critique line ...Wow theyve got ropes and torches ...oh oh ...time to go ...crowds getting bigger and louder ...wheres wyatt Earp when you need him ..?Good luck ...hopefully we'll see progress soon on the tabs issues ...(as the din from the crowd near the rating lines gets louder ) ...:)
     
  86. Jumping up and down with joy , the tabs are back ...yee haaa ! Well done admin ....
     
  87. Yes! Thank you.
     
  88. Recently everyone has been stating the the +DETAILS issue has been resolved in the Folder View, but I was still not seeing it. I decided to reload the screen in the browser and then suddenly it appeared, and continued to appear on all other Folders I looked at. I suspect this is is just an issue with caching and that had I just chosen to clear the cache in the browser that the issue would have been resolved that way too.

    My only outstanding concern now is that I am unable to determine if a LARGER view of a photo is actually available before I mouse-click it to see the larger view. It would be nice to add a message to the screen stating, "Click image to see larger view" and then to only show that message if a larger view is actually available.
     
  89. Ahhhh... Disregard my previous comment. I now see that the mouse cursor changes to a pointing finger when it is positioned above an image which does have a larger view. I am a "happy camper" with the hard work you've done overnight to resolve the outstanding issues. But somehow I still get the feeling that I was part of the Pilot Group while all the bugs were being worked out last night.
     
  90. The tabs; critiques, details, etc.; don't work on the individual photo pages this morning for me. I can't rate or look at details related to any photo. I liked the overall changes yesterday, when they worked but not this morning.
     
  91. I'm going to close this thread because it's getting kind of long and unwieldy.

    New thread on bugs/fixes is here:

    http://www.photo.net/site-feedback-forum/00Q6mS
     

Share This Page