5D mkii random reset

Discussion in 'Canon EOS' started by capture this! by brooke photography in prescott, az, Oct 21, 2011.

  1. I have a 5D MKii and yesterday during a shoot my camera apparently reset 30 minutes into my session and every photo I shot to that point is gone. I ran a recovery twice and can't get them back. I know they were there because I was showing my client the images along and along. The first image on the card was reset to #0001. Stressing bad. : (
     
  2. That is very strange. Normally once the images are written to the card they would not be affected by a camera "reset" - by which I suspect you mean that that the camera was switched off.
    I wonder if you accidentally reformatted the card or similar?
     
  3. Put the card in a card reader, you will probably have 2 folders inside the folder called DCIM, each will contain one session. What ever you do to your camera the images will only be lost if you have reformatted the card, if you didn't do that the images are on there.
     
  4. The images should have actually started in the 5000s. It is very strange because the images were written on the card. Only one folder is on the card with images starting at 0001 (which is why I assumed a reset of the camera somehow but turning off the camera won't reset the number system). Even if some really dumb reason I formatted while shooting (which I didn't) I would be able to recover them. It's like they don't exist at all.
     
  5. If there is only one folder it should be called DCIM, if there is only one folder inside that DCIM folder then you have a more serious issue, normally they go EOS100, EOS101 etc but different bodies behave differently. But don't look on the camera put the card in a card reader, what is the name of the folder inside the DCIM folder?
    Do not touch the card in the camera again, put it in a card reader, a good one, and use the card manufacturers recovery software. I only use genuine Sandisk cards and their software.
    Try another good quality Lexar or Sandisk card and try to emulate the problem, I'd think it was a card issue but for the file numbers restarting at 0001, only the camera can assign file numbers.
     
  6. There is only one and it is 100EOS5D that's it and my numbers aren't continuous anymore. I will try a recovery while in a separate card reader and see if that helps. My husband called Canon and they said maybe a fluke circuit issue, but that should affect the card just the resetting. My biggest worry is, what if that wasn't a portrait session but a wedding? That would be 30 minutes of images gone. I cannot take that chance.
     
  7. Never heard of such a problem on the 5D2. I'd try a different card. Also, when the backup battery dies (the button cell), your get a reset and lose CF and other settings.
     
  8. Brooke,
    Backup at capture is not new, whilst it doesn't help in this situation all film wedding pros would use at least two bodies, this ensured even if a roll of film was lost or scratched in processing another image was available. The 1 series digital bodies offer two card slots so you can duplicate captures in real time, this might not have helped in this case as both might have been damaged, though I have never heard of that happening, but it is a highly regarded feature of the 1 series. That aside, again you should be shooting weddings with two digital bodies as a minimum, normally with a third in a bag somewhere, and mixing it up between the two, this cuts the possibility of catastrophic camera/card failure in half. One of the differences between $500 and $2,000 wedding shooters should be their capture and backup strategies, amongst many other things :). Don't worry about these things, accept that if you do it long enough bad stuff will happen and be prepared.
     
  9. I do shoot with two bodies during a wedding, so that would have helped some yes, however in this case it was 30 minutes of images lost, that's an entire ceremony that maybe would be gone and only have partial on the 2nd. :/ I have had a malfunction of my gear before and always have 3 bodies with me just in case. This weird situation , it was like nothing was wrong. I shot, shared some with my client, shot some more, etc and never even knew anything was wrong until I got home and looked at the images. I actually considered a 1D before for that exact reason, but chose the 5D instead. Thanks.
     
  10. Somebody somehow formatted the card. Whether it was the camera (as part of it's 'reset') or a finger flub, I obviously can't say. But often (assuming you don't write over the data on the card) recovery software can recover data from formatted cards. I've twice used Lexar's software to recover images from formatted cards, I only got some, because I was shooting after the format (and the new images overwrote some of the old ones).
    It may be to late now (as you continued shooting, and writing new data onto the card), but for future reference, the FIRST thing to do in a similar situation is to pull the card and put a new one in. You would be surprised just how good the recovery software is, but a memory card is NOT like a magnetic drive, and therefore once each bit is 'flipped' (written over with new data) there is NO possible way to get it back.
    That said, I've never even heard of any modern camera doing what you've described, but it's certainly possible... I would replace the backup batt, and the primary batt, and upload a new copy of the latest firmware as a preventative measure. Theoretically, the only thing that could practically cause that symptom is the firmware (by itself) running the format card function, then running a complete system reset function... I would be interested if the "reset"reset the shutter count also?
     
  11. Marcus,
    Thanks. The thing about this situation is I had no idea it happened until I got home since we had viewed some of the lost photos on the card earlier. I just went about shooting and sharing for an hour and a half :/ I went out today and got another backup battery. Any thoughts it might be the card?
     
  12. I expect not. (not to say it's impossible, just very unlikely) The thing is, that both the 'problems' are executable instructions in the firmware. And if the memory card controller chip was *that* bad, it's unlikely you would've been able to still use the card. Obviously, the card wasn't full either (else your recovery software would have found something)... IDK, I certainly wouldn't use that card again professionally on the off chance it IS the card, but without some other symptom, there is no rational reason to blame the card.
    So the camera:
    a) reset it's file count (normal rollover, but usually only at IMG9999 -- unless user directed), the 5D2 automatically makes a new folder for new images when this happens
    b) formatted the CF card (again, a normal user executable function),
    It must have happened simultaneously (or at least in relation to exposures), or else you'd have some old images, or not all the new ones.
    My thought about the backup was if you changed batt (or had a bad one in), and it was dead, it may have reset the file count. But that still doesn't explain the format. I use 3-4 different bodies regularly, and (when shooting recreationally) often hot swap CF cards -- Never ONCE have I had the 5d2 or any other DSLR wipe a card by itself. I routinely empty batteries, and have replaced the backups on ALL my units... To me, the format is the mystery -- and the scary part!
    I still would be very interested to know if part of the 'reset' wiped the shutter count, normally that's not possible, but if it did, it would allude to a serious flaw in firmware/hardware, and (I would guess) indicate the source of the problem. EOSinfo (downloadable free) utility tells you what the shutter count is pretty effectively.
     
  13. Brook, Have you had any success recovering the images?
    I personally have a bad habit of leaving the format enhanced on my tool selection. Meaning as I'm scrolling through all my menu options, format is selected as I passed by. And even though it's a multiple step process to reformat the card, it could happen.
    The strange thing for you is that your frame count has changed. When you spoke with Canon what was their explanation?
    I wish the best for you, specially when you have to explain it to your client. I photograph with a 5Dll and two 7D's , and at my last wedding one of my 7D had a software issue that would not allow me to control my shutter speed.
     
  14. Hi William. Thank you for your response. I never did recover them and did a reshoot for the client. She was very understanding. Canon, really had no answer, but said the reset could have been from a weak internal battery :/ I have shot several other sessions since and everything seems back to normal. I did not rule out the possibilities of accidentally formatting, although you're right it is a few steps. Whatever happened, I think the biggest mystery is why wasn't I able to recover the first 30 minutes of her session but all the rest. I may never know.
     
  15. I wanted to add fuel to the fire. I have shot quite a few sessions since this mishap and even with a new internal battery, every time I change the battery My camera wants me to reset the date and time. I think I just need to send it in to Canon :/
     

Share This Page