5D mark IV AF-ON freezes camera

Discussion in 'Canon EOS' started by gordon_blackler, May 10, 2019.

  1. I have a 5D mark IV running firmware 1.1.2 with about 1 year left on the warranty.

    The AF-ON functionality has recently started behaving strangely, without me changing any settings on the camera. It started during an event when the AF-ON button wouldn't focus (I use back button focus and set the shutter to only meter and take the photo). The camera started to lag for several seconds or freeze up entirely and I couldn't take any more photos unless I switched it off then on again.

    After further testing, I see that no matter what function I assign to the AF-ON button, pressing it causes that function to stick and freeze up the camera. If I assign focus, when I press the button, the AF stays on and won't cancel when I release the button. Or if I assign metering to the button, the camera freezes up immediately. If I assign those functions to other buttons, for example if I assign focus to the "*" button next to it, all is ok.

    It doesn't matter which lens I use, whether the grip is attached to the body or not, or which type of battery I use. The problem happens with all or any of those combinations.

    A couple of last points to note.

    - Sometimes the freeze can be undone by half pressing the shutter button. Usually the AF-ON function is cancelled successfully by taking a photo.
    - It doesn't always happen. The problem sometimes only happens for a few photos and then it's fine. Then it comes back again.

    Do you think I should simply send the camera back to the shop or have I missed a setting somewhere?

    Thanks
     
  2. Just some questions to diagnose, trouble shoot, rule out possible causes.
    • Were you using any third party lenses?
    • Where you using a third party grip or teleconverter or other third party devices attached to your 5D MK IV?
    • Are you using the recommended memory cards and not slow cards that can't meet the cameras specs?
    • Does this happen with all lenses?
    • Does the problem happen in all modes?
    I did an internet search and have not heard of any issues with firmware 1.1.2 yet.

    If the problem is happening with Canon lenses and Canon accessories, contact Canon support, you may have a real issue and if Canon can duplicate the issue, there may be a firmware bug that you discovered.

    If the problem only happens with a third party lens, say Tamron or Sigma... or other third party devices and does not happen with only Canon devices then there could be a compatibility issue, I have experienced third party lenses needing firmware upgrades to be compatible with all functions of the Canon 5D MK IV if you are lucky and there is a possibility some older third party lenses just won't have a firmware upgrade available.

    Please let us know what you find for a cause and resolution.
     
  3. Hi Mark,

    After more time testing, I can answer your questions as follows:

    • I have Canon and Tamron lenses. Doesn't make any difference.
    • I'm not using any third party attachments. I have an original Canon grip. The AF-ON issues happens on the body AND on the grip.
    • I'm using fast Sandisk cards - fast enough for 4k video.
    • I have Canon and Tamron lenses. Doesn't make any difference.
    • It happens in all modes except full auto (because you can't assign AF-ON in that mode - there's no access to the "Q" functionality.

    Update: 6th Sept, 2019

    AF-ON button is malfunctioning on the body and grip for all modes I set it to, not just focusing. There is nothing physically wrong with the buttons on the camera or grip so I don't know if it's a firmware bug or some other fault with the electronics. Yesterday I tried to re-install firmware 1.1.2 but it didn't help.
     
  4. If problem is happening with all Canon native gear then you ruled out third party. When you say it freezes, is it locking focus will not take the photo and the red focal point lighting then going out after focus lock or does it stays on locked or is it not locking focus as if it can't find a focal point to lock on to and will not take the photo which could mean you are way over exposed or under exposed an the camera can't find a focal point to lock on?

    You have tried new memory card to make sure you are not having a bad buffer issue with faulty memory cards.

    Try removing the grip and shoot with no grip and see if issue happens. Try putting grip back on. You are sure there are no damaged pins on CF card, no funk or damage on grip electrical contacts into camera. You have your grip switch turned on. You moved the camera lock on and off. Make sure your lens electrical contasct point are clean.

    Do you have a local Canon Dealer, and I mean a real camera shop selling pro gear, not a Best Buy, you want to show the camera to a real experienced camera guy and rule out you are not doing something that is causing this issue.

    You reinstalled firmware, even rolling it back, so that rules out firmware.
    After you checked all the stuff you can and still not figuring out what is going on to resolve the issue:

    Final step is to contact Canon, get an RMA and ship the camera back. I have only had to RMA one Canon camera, a 40D with grip that took a tumble. Cost me $45 and had my local camera shop send it back, this was a few years back. Doing it through them was great as they deal with a lot of gear with Canon and this got a fast turn around. About 2 weeks. My camera was out of warranty and the fall obviously was an accident, not a warranty issue. Prices today may be more.

    It is possible there could be a bad ribbon jumper in the camera not seating propperly or just a plain malfunctioning component. Maybe some other folks here will have some ideas. Good luck.
     
    Last edited: Sep 6, 2019
  5. Thanks for your detailed response, Mark.

    The camera is still under warranty so I can (and probably will) send it back to the camera shop that sold it to me. It was an online purchase. There is no Canon dealer in my city unfortunately.

    So, I'll try to explain what I mean by the camera freezes:

    It's actually very erratic. Sometimes the button does nothing for several presses. Same on the grip. Most often though, in ONE SHOT mode, when I'm looking through the viewfinder and I press the AF-ON button, the AF word appears in the bottom right corner and won't go out. Focusing gets stuck. I have to press the AF-ON button several times to unstick it. Sometimes the only way to cancel AF is to turn the camera off. Sometimes I can take a picture, sometimes not.

    When I have AI SERVO selected and press the AF-ON button it also gets stuck and keeps hunting / trying to focus if I move the camera around. Again, sometimes another press of the AF-ON button will cancel it, sometimes it takes several times and sometimes I can / can't take a photo.

    This is all before I take a picture, so the memory card is not even in the equation yet.

    I've tried with the grip attached and also not attached. I've also tried with the grip attached but turned off. No difference in any scenario.

    If I assign AF & Metering to, for example the asterisk button (usually for AE lock), AF works fine, so the problem is always the AF-On button on the camera and grip. Does that make sense?

    Thanks.
     
  6. Hi Gordon!
    I'm experiencing exactly the same symptoms with my 5Dmiv. It started with the 70-200 2.8 ii, then I replaced it with the 100-400 ii and still the same problems.
    5 days before it, I had left my camera (and my 7Dii as well) to a routine cleaning of its sensor and body at the Canon stand during the World Champs in Athletics.
    But I do not think these issues are related.
    Please, have you found any solution?
    thanks!!
     
  7. One more thought. Do either of you have a remote or wired/tethered shutter release. See if issue still happens. May be a work around.
    Since we have a second person who may have the same issue, you both may want to get Canon involved.
    I suggest posting on the Canon Community site, there may be some Canon folks there that can help.
    If enough people are having the issue, Canon may look into trying to duplicate the issue and come up with a solution. Maybe something that can be fixed in firmware or a part replacement.
    LINK to Forum and please update this thread as there may be others who will be searching for a solution.
     
  8. To me, this sounds more like a bad switch than a firmware problem.
     
    Nick D. likes this.

Share This Page