40D, Manual Mode, Problem Adj. Aperture

Discussion in 'Canon EOS' started by casey_ferguson, Feb 16, 2008.

  1. With my Canon 40d set to full manual mode and the power switch set to the "angled line" function, I'm unable to adjust the aperture setting. Anyone else experienced this, any ideas? Thanks - Casey
     
  2. You have read page 32 of the manual?
     
  3. < snip >
    00ORmF-41760884.JPG
     
  4. Works on mine, using the angled line position. Adjustment via the rear wheel.
     
  5. William

    William Moderator Staff Member

    >>> any ideas? <<< Have you spun the QCD (Quick Control Dial) in BOTH directions, the aperture might be at either extent and cannot go any further? WW
     
  6. Mine works fine unless aperture value is maxed out.
     
  7. I have spun the wheel in both directions, and have indeed read pg. 32 and 90 of the manual. I think it may be a communication between the body and lens situation, perhaps? It is a sigma lens. I have not tried any canon lenses. thanks for the responses everyone.
     
  8. William

    William Moderator Staff Member

    >>> It is a sigma lens. I have not tried any canon lenses. <<< Ah, well next test would be to try the Canon Lenses . . . we await the answer. WW
     
  9. Casey, Older Sigma lenses work with Canon bodies only at max. aperture. Some however, can be rechipped by Sigma and - AFAIK - they will be happy to do it for you. Please specify what type of Sigma lens you are using and I try to check what you can/cannot do with it. (a few years ago I received a compatibility chart from the local Sigma dealer) Good luck, Istvan
     
  10. "It is a sigma lens. I have not tried any canon lenses. " Oh my... Only recent vintage Sigmas will work on Canon's latest. I used to have to upgrade my Sigma ROM chips every year when I bought a new body. Eventually Sigma stopped supporting my Sigma models and I had to toss them. All were of mid-to late 90s vintage and in 2001, they really weren't very old.
     
  11. OTOH I have not heard of compatibility issues with recent Sigma lenses. How old is your lens?
     
  12. Casey, Go to your Custom Function setting (page 152 of the manual ? the 2nd icon from the right) and go to Auto focus/Drive and choose 0:Normal. That's all I hope this helps!
     

Share This Page