“A server error occurred. Please try again later.”

Discussion in 'Photo.net Site Help' started by cfd, Dec 3, 2017.

  1. cfd

    cfd

    When being logged in with my existing account and then navigating to any forum the page just says “Photo.net Photography Forums - Error; A server error occurred. Please try again later.” E.g. when opening Photo.net Photography Forums the server responds with HTTP status code 500 (Date:Sun, 03 Dec 2017 14:48:02 GMT)

    After logging out I can view the forums but obviously I cannot post messages.

    I have tried reaching out to photo.net through their contact form but have not heard back from them after a few days.

    I have signed up with another email address just to be able to write this post.

    Any help is appreciated.

    Regards,

    Dirk
     
  2. I had the same issue. It was caused by me changing the login email address. The email address I used to register is no longer active. So I changed it to my current email address. I was able to login to the main site but could not login to the forums. It is as if the two are linked and if one is changed it does not follow.

    I too filed a request but heard nothing in return. It is as if Photo.net in a one man operation with tons of issues (posted here) to fix.

    I am still at that point where I cannot get email notifications because they are going to a dead account. If you did not change your email login on your profile then there is something else working it's evil.
     
  3. cfd

    cfd

    Thank you, Brian. Could be the same issue. I think I also changed my email address a while ago. Probably I haven't posted anything since then.
     

Share This Page